[Cartoweb-users] Problem getting CartoWeb3 demo to run

Sebastian Albrecht albrecht at fielax.de
Thu Jul 28 13:23:17 EDT 2005

Hello cartoweb users and developers,

I've just found CartoWeb today and installed it right away. Passing
different problems with my php configuration (--enable-soap was
missing f.e.) I got to run the htdocs/client.php.

Now I'm stuck with the htdocs/demo.php. I downloaded the demo
and installed the data directory.

When I try to access the demo.php file using my browser it says:
When I run the demo.php file from command line it says:
"Memory Access Violation".

I tried to debug the code following the php method calls. The error
occurs at line 77 in CartoserverService.php:
$result = $this->getCartoserver()->$function($argument);

var_dump said:
$this->getCartoserver() is an object (not null).
$function is "getMap".
$argument is an object of MapRequest (not null).

Does anybody know what might be the problem? Could it be a php
configuration/compilation or php.ini thing?

Thanks very much for any hint and best regards,

My versions:
Suse Linux 8.2
PHP 5.0.4
Mapserver 4.4.2
CartoWeb 3.0.0

More information about the Cartoweb-users mailing list