[Chameleon-dev] [Bug 110] [Chameleon] Code Review - Widget.php
Fri, 14 Nov 2003 11:48:51 -0500 changed:

           What    |Removed                     |Added
           Keywords|                            |CodeReview

------- Additional Comments From  2003-11-14 11:48 -------
Widget.php version 1.43  2003-11-05

* update copyright
* @author tag needs review
* comment priority defines
* change priority defines to integers (and other defines)
* naming conventions for priorities?  use numbers? make proposal to  Definitely remove PRIORITY_GOD
* what is AUTO_PROJECTION_UNIT needed for?  Should Widget contain ReprojectAuto
* class comment needs details, including example .. .abstract base class
* group member variables more logically
* comment at least some of the member variables
* moApp should be mroApp
* look for other member variables that are references
* need to consider implications on changing member variable names.
* should put comments around member variables for public, private
* update comment for constructor
* need to ensure that $lang is validated somewhere
* initialize language stuff to null if not used?
* move oCommonMLT into Chameleon.php and access via moApp
* in ValidateAttributes, change foreach to a for loop. 
* in ValidateAttributes, change double to single quotes
* ValidateAttributes needs a comment
* SetMap should be SetMapRef and comment should reflect it.  Consider renaming
to mroMapSession, .... also, document that it is a MapSession object.
* change to SetSharedResouceWidgetsRef, fix comments
* change to SetURLRef and fix comments
* ParseURL comment should describe return value
* SetUniqueId fix comments

continue on Monday ...

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

This archive was generated by Pipermail.