[Chameleon] PHP/MapServer/PROJ issue, Invalid or no access to template/context

Maciej Sieczka tutey at o2.pl
Fri Jul 6 17:53:51 EDT 2007


I'm trying to deploy Chameleon. Although I have put the

SetEnv PROJ_LIB "/usr/local/share/proj/"
SetEnv GDAL_DATA "/usr/local/share/gdal/"

in my apache config, as well as the

CONFIG PROJ_LIB "/usr/local/share/proj/"

in all *.map files comming with chameleon, when opening any Chameleon
Sample Applications I still get errors like:

PHP Fatal error:  [MapServer Error]: msProcessProjection(): unknown
projection id in
/home/www/chameleon/htdocs/widgets/Locate/Locate.widget.php on line 430

Is there some PHP config option to direct it to the place where the
epsg file resides? Those tweaks cited above used to help me when using
the UMN Mapserver alone, or via p.mapper.

Also, the temporary *.php files in my /ms_tmp/ are full of:

$this->aszMLT['core'] = array();
$this->aszMLT['core']['en-CA'] = array();
$this->aszMLT['core']['en-CA']['0'] = 'FATAL ERROR: Invalid or no
access to template';
$this->aszMLT['core']['en-CA']['1'] = 'ERROR: You don\'t have
permission to change template.';
$this->aszMLT['core']['en-CA']['2'] = 'ERROR: Invalid or no access to
$this->aszMLT['core']['en-CA']['3'] = 'ERROR: You don\'t have
permission to change context.';
$this->aszMLT['core']['en-CA']['4'] = 'ERROR: Invalid map file.';
$this->aszMLT['core']['en-CA']['5'] = 'WARNING: Invalid maturity level
in chameleon.xml.  Contact your administrator';
$this->aszMLT['core']['en-CA']['6'] = 'WARNING: Login Failed -
Incorrect Username and/or Password';

What template and context files does it want to change? I have tried
whatever I thought could be related in the CWC2 and Chameleon
configuration, access rights to folders etc. but my blind guesses don't

Please, bear with me and give me some guiding. I really tried hard
searching the Chameleon mailing lists archives and reading whatever's
available on the net but no go.

I'm happy anyway that after two days of reading and working I made it
to install and run Chameleon at all. Only that can't see any maps yet,
only an empty frame and icons. Hopefully this is just temporary, cause
from the examples I saw on the net I really liked Chameleon's design
and flexibility and can't wait to make'em mine :).

Using Chameleon 2.4.1 on Ubuntu Dapper, Apache 2.0.55 and PHP 5.1.2
from standard Dapper repos, UMN Mapserver + Mapscript 4.10.2 from
source, PROJ 4.5.0 from source.


More information about the Chameleon mailing list