[Chameleon] Having trouble expanding map to table extents

Andrew Parker aparker1969 at yahoo.com
Sun Mar 11 19:56:19 EST 2007

I am customizing the sample_enhanced template.  After numerous hours of playing around (and learning) html, I am almost where I want to be.  Except that I cannot get the main map to expand to fill the area between the compasspoints. 

When I moved the MapDHTML to the center cell of the compasspoint table, the map no longer filled the compasspoint area like it used too; the map now has a large compasspoint border.  I did this so the Tools table to the right of the map would be visible as the user changes the size of the map.  I tried changing the size of the map in the mapDHTML, the css file, the map file...northing worked.  What is the proper code to fix this?

Attached is an image of the map.  I made some of the table borders visible so the user list cant see how I have set up the table which has two columns, the main map column, and the column to the right which has the Tools.  Also attached is the source code files: sample.css, test1.map, and template.html. 

Lastley, I moved the reference table to a table row below the main map table and tool table.  This was the only way I could get the reference table to move as the user changes the size of the map.  I am sure there are cleaner ways of doing the above, but I am in the learning stages and just know enough to be dangerous.

Thanks in advance for the help!


Be a PS3 game guru.
Get your game face on with the latest PS3 news and previews at Yahoo! Games.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maptools.org/pipermail/chameleon/attachments/20070311/74b06c37/utf-8qtemplate-0001.html
-------------- next part --------------
A non-text attachment was scrubbed...
Name: =?utf-8?q?sample.css?=
Type: text/css
Size: 2534 bytes
Desc: not available
Url : http://lists.maptools.org/pipermail/chameleon/attachments/20070311/74b06c37/utf-8qsample-0001.css
-------------- next part --------------
A non-text attachment was scrubbed...
Name: =?utf-8?q?test1.map?=
Type: application/octet-stream
Size: 12439 bytes
Desc: not available
Url : http://lists.maptools.org/pipermail/chameleon/attachments/20070311/74b06c37/utf-8qtest1-0001.obj
-------------- next part --------------
A non-text attachment was scrubbed...
Name: =?utf-8?q?problemMAP.png?=
Type: image/png
Size: 81406 bytes
Desc: not available
Url : http://lists.maptools.org/pipermail/chameleon/attachments/20070311/74b06c37/utf-8qproblemMAP-0001.png

More information about the Chameleon mailing list