[Chameleon] CwcImage_0 when upgrading to Chameleon 2.6

john lace johnlace65 at hotmail.com
Tue Sep 2 22:25:23 EDT 2008

Dear Jeff and Justin:
Ms4w 2.2.9 solved the problem on windows ms4w.   Now I have buttons.  
But the problem with linux seems even darker.   Is this a problem caused by a newer version of a program, that I need to update?  A configuration that changed in apache for the newer ms4w?    
I have three linux boxes, two with php4, one with php5, First two are centOS4, the other is CentOS 5.   All have MapServer 5.   All work with chameleon2.4,  none does for chameleon 2.6.  
Could you shade any light on this?   Can you think of a program/config that I may try first, before upgrading everything ?   Any clue will be appreciated.
John Lace
> Date: Tue, 2 Sep 2008 16:25:38 -0400> From: jmckenna at gatewaygeomatics.com> To: chameleon at lists.maptools.org> Subject: Re: FW: [Chameleon] CwcImage_0 when upgrading to Chameleon 2.6> > John,> > I can speak regarding your ms4w issues: the chameleon package (on the > MS4W downloads page: > http://www.maptools.org/ms4w/index.phtml?page=downloads.html) needs *NO* > configuring in order to work with MS4W 2.2.9. If you are using that > exact chameleon package and MS4W 2.2.9 and still getting those errors > that would be really really odd.> > > -- > Jeff McKenna> FOSS4G Consulting and Training Services> http://www.gatewaygeomatics.com/> > john lace wrote:> > > > Dear Justin:> > > > No, it wasn't your fault. I didn't explain my findings correctly. > > The hover doesn't work, and the right click will point (when on a > > cwcimage_0) to the original button location ../skins/sample.., not to > > the ms_tmp copy, in firefox; and it points to the sample_basic.phtml, > > in internetExplorer. > > > > I think that I understand the basic ms_tmp process. Chameleon and > > MapServer write to a file path, so we need to configure the > > button_cache_path (for buttons) and the tmp_img_path (for scale and > > other images). And Apache needs a url, so we need the corresponding > > button_cache_web_path and the tmp_web_path. > > > > I've tried modifying these, and the images path work well, but not the > > buttons config. I discover that in ie the tmp buttons get created only > > when you exit ie and reenter. That's why I didn't notice buttons > > written there before. I even moved the full ms_tmp to avoid possible > > conflicts with symlinks. > > > > > > I've tried something else. Forgetting linux for a while, I installed > > ms4w on a new winXP computer, with Chameleon24ms4w. I only changed the > > mapscript_module config to point to php_mapscript_44.dll (or _46.dlls, > > same result). The sample_basic.phtml works Ok. But as soon as I > > install Chameleon26ms4w, the same cwcimage_0 text, all over the page. > > All were downloaded today from www.maptools.org <http://www.maptools.org/>> > > > Do you think that we need to file this as a bug?> > > > Thanks for your reply> > > > John Lace.
Reveal your inner athlete and share it with friends on Windows Live.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maptools.org/pipermail/chameleon/attachments/20080902/90f35786/attachment.html

More information about the Chameleon mailing list