[FGS] [x86_64] Install Mapserver on x86_64

Normand Savard nsavard at mapgears.com
Tue Jun 8 20:31:48 EST 2010


I created another basic package with the missing postgresql-server 
package since the posgis-lib package was included.  I also added an 
extrabasic package without the postgresql-server and  posgis-lib packages.

The apache error comes from this code in /path/to/fgs/etc/init.d/apache

if [ $USER = 'root' ] ; then
    [ `grep -c '^apache:' /etc/passwd` -eq 0 ] && /usr/sbin/adduser 
apache -s /sbin/nologin -d $FGS_HOME/www -c 'Apache - FGS' 2>/dev/null
    # make sure that user apache has been created
    if [ `grep -c '^apache:' /etc/passwd` -ne 1 ] ; then
        echo "! Cannot create user 'apache', could not start apache as 
        exit 1
I think this is the "adduser" command that causes the problem though I'm 
not sure.  You could remove the 'apache' package by doing 'fgs remove 
apache-module'.  You could then download the apache package from the 
maptools Web site, untar it and modify the faulty command.  You tar it 
again and do 'fgs install apache-module /path/to/new_apache_package'.  
That could work.  Or you can add manually the  apache user to the 
/etc/passwd file before installing with the self-installer.

The FGS environment is a self-contained environment.  It could cause 
many side-effects to use it without the provided apache.  I never tried it.



Vincent Letocart wrote:
> I tried the "basic" package and this works indeed much better! There remain 
> a few error messages:
> 	+ Running postgis-lib's installation script :
> 	! cannot convert $libdir in lwpostgis.sql or postgis.sql: no such file..
> 	! cannot convert $libdir in lwpostgis_upgrade.sql or postgis_upgrade_xxx.sql: no such file..
> 	! cannot convert $libdir in spatial_ref_sys.sql, no such file..
> 	+ Starting 'apache':
> 	! Cannot create user 'apache', could not start apache as root.
> [See attached file for the full output]
> Actually, the machine where mapserver should run has apache2 already
> installed, and the "databse stuff" (mysql) is running on another machine.
> Maybe you try to be too flexible with your installation ? :)
> Do you know if it is possible to specify an external database to use,
> and to use the already installed apache2 instance running on the server ?
> Regards
> Vincent

More information about the Foss-gis-suite mailing list