[FWTools] problem configuring mapserver with gdal-config in fwtools

Frank Warmerdam warmerdam at pobox.com
Tue Feb 14 08:47:05 EST 2006

marco barra wrote:
> Hi all
> I have a problem with gdal_config,I have installed (and tested 
> installation using ogr2ogr etc)fwtools and it works,but  I can't 
> configure mapserver using: ./configure 
> --with-gdal=/.../.../FWTools-linux-1.0.0a7/bin_safe/gdal-config  or 
> ./configure --with-gdal=/.../.../FWTools-linux-1.0.0a7/bin/gdal-config
> I have added path to bin_safe to my bashrc.
> Can someone help me
> Thanks .......and sorry for my english


I tried this on my system and it worked.  My steps were:

1) Setup the environment.  At the shell (or in your bashrc) source the
    FWTools setup script.  This sets much more than just the PATH.

2) Configure MapServer 4.8.1.  In this case I explicitly include PROJ
    support.  If you don't, you will run into a problem due to a PROJ_LIB
    conflict, and you will need to clear the PROJ_LIB setting in Makefile
    by hand. I have fixed in this now in 4.9 CVS.

    ./configure --with-gdal=/usr3/pkg4/OpenEV_FW_Tree/FWTools/bin/gdal-config

3) Build (ie. make).

Best regards,

I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Programmer for Rent

More information about the FWTools mailing list