[FWTools] Error viewing S-57 files

Frank Warmerdam warmerdam at pobox.com
Fri Nov 21 12:04:38 EST 2008

Lim Chee Kiang wrote:
> Hi,
> I'm new to using fwtools. I tried to view an ENC file (*.000) using 
> openev but the program crashed. I thought these formats are supported 
> through the ogr library. Can someone offer some advice? Thanks


Generally speaking it should work.

Have you tried loading any other spatial data with OpenEV?  Did it work?
If you are on linux, and OpenEV crashes the first time raster or vector
data is displayed, then you should try adding the "-h" flag on the commandline
to use native OpenGL.

If it is only s57 files causing problems, then I'd suggest trying with a
well known file (such as http://home.gdal.org/projects/s57/us5tx51m.zip).
If the us5tx51m file works ok, then the issue might be specific to your .000
files.  In particular there have been some issues with multi-byte text in them
which are hopefully now fixed.

Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Programmer for Rent

More information about the FWTools mailing list