[ka-Map-users] First installation of kamap.

hazmy hazeman hazmy.hazeman at gmail.com
Wed Dec 7 20:58:35 EST 2005


Im really new to kamap and I have tried google and searching the archives
for solutions but could not found any. When I tried to open the URL and I
have found this error message.

[MapServer Error]: msEvalRegex(): String
(/opt/fgs/apps/gmap-ms40/htdocs/gmap75.phtml) failed expression test. in
/opt/fgs/www/htdocs/ka-map/init.php on line 44

Warning: Failed to open map file /opt/fgs/apps/gmap-ms40/htdocs/gmap75.phtml
in /opt/fgs/www/htdocs/ka-map/init.php on line 44

Fatal error: Call to a member function on a non-object in
/opt/fgs/www/htdocs/ka-map/init.php on line 63

This is what I have done:

OS: Fedora 3.

1. First I installed fgs-gmap-demo-0.2.4-linux-i386.bin, to test the demo
file.  Everything is working fine. I can view the demo map.

2. Then I copied kamap htdocs (kamap-0.1.1) into /opt/fgs/www/htdocs/ka-map/

My config file:

$szPHPMapScriptModule = 'php_mapscript_46.'.PHP_SHLIB_SUFFIX;
$szPHPGDModule = 'php_gd.'.PHP_SHLIB_SUFFIX;

$aszMapFiles = array(
  "gmap"   => array( "GMap", "/opt/fgs/apps/gmap-ms40/htdocs/gmap75.phtml",
                     array( 15000000, 7500000, 3000000, 1000000 ),

$szMap = 'gmap';

Any guide to solved this problem would be appreciated.

More information about the ka-Map-users mailing list