[ka-Map-users] Newbie: Need help with IIS configuration???

Todd Fagin tfagin at coordinatesolutions.com
Wed May 23 17:52:31 EDT 2007

Greetings Ka-Map users,


I am an extreme newbie to the world of Ka-Map and am having problems getting
the application to work.  I have worked with MapServer before, though,
primarily writing and testing map files that others eventually deploy.  I am
pretty ignorant about all things server related, so please bear with me as I
try to explain what I have done and the problems encountered.  I cannot
guarantee that I will always use the correct terminology to explain things.


First things, first:  I am running IIS 5.1 and recently installed the latest
version of PHP for IIS.  I confirmed the installation was successful via a
simple "hello world" program using the PHP echo() statement. Also, as
previously alluded, I already had MS4W installed and working.


Second, since I am using IIS instead of Apache (which all of the
documentation I have been able to find seems to be related to Apache), I
decided to use my very limited knowledge of servers to proceed.  I created a
virtual directory called kamap under my default website and pointed this to
the appropriate directory (in my case C:\ka-map-1.0\htdocs).


Next, following steps in both the Ka-Map wiki and Tyler Mitchell tutorial
<http://www.xml.com/pub/a/2005/08/10/ka-map.html?page=1> , I configured
Ka-Map (version 1.0).  Originally, I tried to use a map file that I had
previously written. I have used this map file in a MapServer application
before, so I know there aren't any problems with it.  I nonetheless ran
shp2img to confirm this.  Again, no problems with the map file.  


Nonetheless, once I made appropriate changes to the include/config.dist.php
file and renamed it config.dist, I could not get my Ka-Map application to
work.  Perhaps I am going about this incorrectly, but what I did was, using
my browser (Firefox in case that information is of use to anyone),
I entered the following url: http://localhost/kamap/index.html.  And, as you
can guess, I did not get a map.


So, I decided to follow Tyler Mitchell's tutorial a little closer and use
the map file and data he uses: global.map. Again, using shp2img I confirmed
there were no problems with my map file.


Still, no map.  I tried some additional tweaking, moving the map file and
data to different directories (and ensuring I updated all relevant lines of
code when I did so).  I put the map file in the /include directory. I put it
in htdocs directory.  I put it in its own directory.  No matter what I did,
no map.


Finally (well, I actually did this as I went along, too), I followed the
various suggestions in the troubleshooting section of the wiki.  The last
item seems to be the biggest clue to date: "If you are still having
problems, you can try loading the init.php file into your URL."  And that I
did: http://localhost/kamap/init.php:


And here is what I get:


Warning: dl() [function.dl <http://localhost/kamap/function.dl> ]: Not
supported in multithreaded Web servers - use extension=php_mapscript_46.dll
in your php.ini in C:\ka-map-1.0\htdocs\init.php on line 118

Fatal error: Call to undefined function ms_newMapObj() in
C:\ka-map-1.0\htdocs\init.php on line 124


Per the warning, the best I can tell, I AM using


$szPHPMapScriptModule = 'php_mapscript_46.'.PHP_SHLIB_SUFFIX;


As for the fatal error, I am stumped (line 124: $oMap = ms_newMapObj(
$aszMapFile['path'] );


Any suggestions, tips, constructive berating, etc. would be greatly
appreciated.  Feel free to contact me off list, if you please.




Todd Fagin


Coordinate Solutions, Inc.

501 N.E. 15th St.

Oklahoma City, OK 73104

405.740.4324 (voice)

904.471.5548 (fax)





-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maptools.org/pipermail/ka-map-users/attachments/20070523/4588d971/attachment.html

More information about the ka-Map-users mailing list