[ka-Map-users] Architectural questions.

The Bun rosario.carbone at ipl.com
Fri Nov 9 08:32:07 EST 2007

> Because I'm the author of big chunks of OpenLayers :) 

aaaaaah now I understood, you could have been offended, sorry about that,
again mine were first thoughts not definitive statements, I am still
building my puzzle and only at the end I can express final and conclusive

Can you help to finish the puzzle? Can you help with the setting of
If I can run Tilecache up to OpenLayers and Mapserver I have a complete
overview of the possible architectures combinations and then I can decide
what is the best for me on the bases of facts.

At the moment I cannot go over the "pink" stage with Tilecache. Mapserver
and OpenLayers are all working as I run few examples. But before we go
further I need to specify that I am coming from a complete different
Windows, SQL Server, ESRI and MapInfo, IIS, ASP.NET and C# and I am going to
develop for Unix, Oracle (SDO and ArcSDE), Apache, PHP and one or more of
the Open sources we are talking about, but anyway I have a long GIS
background, which only help a bit in this context.

I am a novice then and I am not very familiar especially with Apache and
Python and then I guess I have done something wrong during the installation
of tilecache.

At this stage I am still prototyping on my Windows machine, so I installed
ms4w for Mapserver, with the Apache configuration that comes with it
(mapserver.exe, it is windows not unix etc), then I installed Python on my
machine ("C:\Python25"). Finally installed tilecache which I'd like to run
in CGI mode. First attempt I copied in the cgi-bin folder the same of
mapserver.exe and second attempt in a new folder called "tilecache" at the
same level of the cgi-bin folder:




I added in httpd.conf:

<Directory "/ms4w/Apache/tilecache">
    AddHandler cgi-script .cgi
    Options +ExecCGI

and restarted apache.

I created a tmp folder under ms4w changed tilecache.cfg this way:



and I left the [basic] layer configuration the way it already was:


I changed the first line of the CGI this way:

#!C:/Python25/python.exe -u

Finally I tried this code:

var map = new OpenLayers.Map("map");
layer = new OpenLayers.Layer.WMS( "my layer",
"http://localhost/tilecache/tilecache.cgi?", {layers: 'basic', format:
'image/png' } );
map.addControl(new OpenLayers.Control.Permalink());

and I get a white map, when I zoom in I get two "pink" tiles, zoom in and I
get more "pink" tiles and so on.

If I change:




I get the same result, apparently there is no message in the Apache log??? 

I can't understand where is the error:

1) Apache configuration.
2) cgi configuration
3) python (location or code)
4) cgi (location or code)

Have you any idea?

Kind Regards
Rosario Carbone

View this message in context: http://www.nabble.com/Architectural-questions.-tf4759229.html#a13667019
Sent from the ka-map-users mailing list archive at Nabble.com.

More information about the ka-Map-users mailing list