[maplab-users] projection questions.

Paul Spencer
Wed, 28 Aug 2002 16:08:14 -0400
Scott, the preview window was intended to be used that way ... but not 
as a work-around to bugs :)  This same error was reported by Steven 
Woodbridge on the mailing list but it happened under slightly different 
circumstances, I *think* his problem was solved by upgrading to the 
latest development version (I didn't see any response from him on it 

Can you please grab the latest rc3-dev version and see if the same thing 
happens?  We are meeting tomorrow to prioritize work for RC3, we are 
hoping to release it at the end of next week.  It should be the last RC 
before the MapLab 2.0 release.  I'd really like to know if this is an 
old bug that's been fixed or a brand new one that has to be fixed.

We will also try to investigate this.  Dean, can you help out on this 
one and provide Bill with a map file and data that would simulate this 
problem.  If you need more info, contact Scott Tweedy directly.


Paul Spencer
Applications and Software Development
DM Solutions Group

Daniel Morissette wrote:
> Hummm... bizarre.. I'll forward this to the maplab-users list where one
> of the MapLab developers can hopefully suggest something.
> Daniel
> "Tweedy, Scott" wrote:
>>The behaviour is a little weird.  I can open a valid .map file and preview
>>it.  If I close the preview window and make any changes and attempt to open
>>the preview window again, I get the error now.  I've taken to leaving the
>>preview window open all the time and just redrawing the map within the
>>preview window when I make changes.  I'm not sure if that's how it was
>>intended to work or not though.
>>I've tried different combinations for the layer in question that I first
>>noticed the error happening with.  I a projection defined at the MAP level,
>>it is a Lambert Conformal Conic.  I've added an ECW file as a raster layer,
>>it's original projection is UTM.  At this point everything was fine.  When I
>>went to add a vector layer that had an original projection of lat/long I
>>originally got the error.  Each layer had valid projection definitions as
>>far as I could tell.
>>-----Original Message-----
>>From: Daniel Morissette []
>>Sent: Wednesday, August 28, 2002 3:33 PM
>>To: Tweedy, Scott
>>Cc: MapLab Users (E-mail)
>>Subject: Re: [maplab-users] projection questions.
>>"Tweedy, Scott" wrote:
>>>Fatal error: MapServer Error in msProcessProjection(): projection not
>>>in E:\maplab-beta6\common\wrapper\map_session.php on line 721
>>I think I've seen this before, but can't remember why it happened.
>>Could it be that one of your PROJECTION/END blocks is empty?  Make sure
>>all the layers that contain a PROJECTION object contain a valid
>>projection definition.
>> Daniel Morissette     
>> DM Solutions Group    
>>  Don't put for tomorrow what you can do today, because if
>>      you enjoy it today you can do it again tomorrow.
> _______________________________________________
> Maplab-users mailing list

This archive was generated by Pipermail.