[maplab-users] Maplab frustration!

William A. Bronsema, C.E.T.
Thu, 27 Mar 2003 12:43:31 -0500

Have you tried down-grading your php to 4.2.3?  It is very easy to run 
multiple versions of php on the same server.  I  haven't tried 4.3.2 
with Maplab and can't guarantee that your problems aren't stemming from 
that.  As indicated in the install docs, Maplab was built using 4.2.x 
and is the version that is currently supported (4.2.3 being more stable 
than 4.2.1 and 4.2.2).


Matt Doggett wrote:

>I was at first very excited about using Maplab, however, after several
>days and it *still* doesn't completely work, I'm about ready to give up
>on it.  Has anyone out there used it successfully using:
>Mapserver 3.6.4
>Php4.3.2rc1 (to fix the PHP_SELF problem) 
>Has anyone else successfully installed & run maplab with this
>I've followed all the installation instructions (to the T) but I get
>error messages on so many aspects of Maplab, it's not realistic to post
>them all, here are a few:
>- Can get the initial preview of a Map but any actions on that preview
>result in a blank map.
>- Legend is empty in the preview.
>- MapBrowser fails miserably with "Warning: mkdir(/data/3e822b2834ef6/)
>[function.mkdir]: No such file or directory." Errors galore!
>- GMapFactory can't create a new project with the following error: 
>Warning: main(/htdocs/gmapfactory/structure.php) [function.main]: failed
>to open stream: No such file or directory in
>/home/precip/www/maplab/htdocs/gmapfactory/appframeset.phtml on line 136
>It seems I'm getting lots of path-related errors and no matter how I
>setup the configuration files, they won't go away.
>Matt Doggett
>Spatial Climate Analysis Service
>Oregon State University
>316 Strand Ag Hall
>Corvallis, OR 97331
>Maplab-users mailing list


 William A. Bronsema, C.E.T.                DM Solutions Group Inc.
 Applications Developer        
 "The ancestry of every action is a thought"  -  Ralph Waldo Emerson  

This archive was generated by Pipermail.