[maplab-users] Confusion over map redraw during query[Scanned]

kgrootendorst at baird.com kgrootendorst at baird.com
Fri Apr 22 13:13:22 EDT 2005

I'm reposting this to the list - didn't make it through last time....

In an earlier post you mentioned that you want the scale to be at:  0, 0, 
70,000, 130,000 :
Hi Zak,
 I couldn't see any error messages that appeared relevant. I tried what 
you suggested, removed all the layers, trying the map with one layer at a 
time and the problem still occured. 
 I am a bit confused about the extents- when I run the shape files and 
rasters in Arcview I get the extent 0, 0, 70000, 130000 which is correct 
for the British National Grid. That's what the extent is set to in my map. 
But the extent shown in the MapBrowser box is the extent for the frame, 
which appears to put the rectangular map in the centre of the square and 
pad it to either side. If I set the map frame to be the same proportions 
in pixels as the map size is in metres, ie 700 wide by 13000 tall (or 
sensible fractions of these) then it still puts the map right in the 
centre, it doesn't make it fill the frame, which is what I thought it 
would do.

When I query the map and it redraws very small, the extents and scale 
shown below the frame don't change from what they should be if the map was 
drawn correctly.
Thanks again for your help

But your map file indicates:  EXTENT 0 0 700000 1.3e+006
Both x2 and y2 are 10 times greater than what you want (eg. 700,000 and 
1,300,000 instead of 70,000 and 130,000)

Could this be the problem?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maptools.org/pipermail/maplab-users/attachments/20050422/d6fe955c/attachment.html

More information about the Maplab-users mailing list