[maplab-users] continuing jvm problems

joanne cook j.cook at oxfordarch.co.uk
Thu Feb 3 04:18:13 EST 2005

Hi List,
In my continuing quest to try and sort out the problem I (and others) have been having with gmap factory maps not displaying with different jvms, I found out a few more things. To recap- the symptom is that the page loads, says it's loading the map, but then no map displays. The sun java console says:
"Loading map...please wait
Try as PNG
start: Development Version [followed by a date]"
It works fine with the microsoft jvm.
First, updating to the most recent sun jvm didn't help. 
Second, the problem only arises when using gmapfactory- the same map displays in mapbrowser and mapedit preview.
Third, the image isn't created, ie there's no map in the temporary file, but when I view the source of the page and paste the resulting map url into a new browser window the map does display.
Fourth, I've tried replacing the rosa.jar in my gmapfactory application with one that I know works from mapbrowser, and I've tried changing the path to rosa.jar in the code to one that I know works. 
Fifth, I get this problem with both IE6 and Firefox 1
So, given that I don't have the problem using mapbrowser, I'm wondering what the differences are in the way that things are done in gmapfactory- and how I can hack the code to make it work more like mapbrowser. I'm not a java person, or really a webdesigner so I'm a bit out of my depth trying to sort this out myself but I'll happily try anything people can suggest. Any thoughts?
Joanne Cook
Oxford Archaeology North

More information about the Maplab-users mailing list