[maplab-users] mapedit preview map returns internal server error

Jeff McKenna jmckenna at dmsolutions.ca
Tue Aug 1 08:43:47 EDT 2006

MapServer uses GDAL for raster support, so yes tifs and mrsid images are 
handled by GDAL.

However I can't explain your problems.  I see that you are on Windows - 
I know that MS4W was recently modified to included mrsid support by 
default.  But I have not played with MrSID files in MapLab.

MapLab was built so long ago, long before virtual spatial support was 
added to OGR (ovf files), so I'm not surprised that there might be 
problems with those files in MapLab.

You might have to live with this 'quirkiness' for now.  Unless someone 
else sees a solution?


Bryan Keith wrote:
> Thanks, Jeff.  Previously I wrote that I had 3 shapefiles and a tiff. 
> That was wrong.  I have 3 shapefiles and a sid image.  I removed the 
> sid, and then "preview map" worked fine.  Then I added the sid back in, 
> and "preview map" still worked fine.  Hmm.  The map files are identical 
> again.  I opened the original mapfile, and I got the error.  I opened 
> the new map file, and I also got the error.  I removed the sid, and 
> "preview" map worked again.  Back where I started, and I can reproduce 
> the problem (remove the sid, everything works...).  Does this 
> information help locate the problem?
> Does MapLab (and MapServer) use GDAL for tiffs?  I assume it uses GDAL 
> for sids.  I'm wondering if GDAL/OGR are working correctly with MapLab. 
>  When I built the map file, I used an OGRCONNECTION to plot points from 
> an ovf (VRT) file.  I had problems with that mapfile and converted the 
> ovf to a shapefile in a quick attempt to get things working.  Again, the 
> problem wasn't with the mapfile and the ogrconnection (shp2img worked) 
> but apparently with "preview map" in MapEdit and the ogr connection 
> (though I should do more testing to confirm this).  I'm planning on 
> replacing the shapefile with the ovf.  In the meantime if this sounds 
> familiar to anyone, let me know.
> I hope all this is clear.
> Bryan
> Jeff McKenna wrote:
>> hmm, could you try removing layers to make the mapfile even simpler 
>> and still throw the error?  And then possibly attach that single-layer 
>> mapfile to an email sent back to this list so all can see.
>> jeff
>> Bryan Keith wrote:
>>> Hello,
>>> I installed ms4w and maplab on a windows 2000 machine and 
>>> successfully made and deployed a simple mapping application on our 
>>> intranet.
>>> Now I can go to MapEdit and open the map file.  When I try to 
>>> "Preview Map", I get an "unhandled win32 exception occurred in 
>>> php.exe" and "internal server error".  "Preview Map" worked fine 
>>> while I was building the map file before deploying with the GMap 
>>> Factory.  It's the same map file that's used in the deployed 
>>> application that continues to work. Also, that map file returns a 
>>> good image using shp2img.  Also, "preview map" still works with the 
>>> tutorial map file.  The problem map file is quite simple: 3 
>>> shapefiles and a tiff.
>>> Anyone know what's going on here?  If you need more information to 
>>> help figure out the problem, please let me know.  Thank you.
>>> Bryan
>>> Bryan Keith
>>> GIS Specialist
>>> Geomega, Inc.
>>> Boulder, CO, USA

Jeff McKenna
DM Solutions Group Inc.

More information about the Maplab-users mailing list