[ms4w-users] New user to MS4W configuration problem with Itasca/Demo

john rust imgahn2u at yahoo.com
Mon Jul 10 16:03:26 EDT 2006

  That was the problem.  I have *not* been using the MapServ_demo link. 
  Have always double clicked directly on index.html within the mapserv-demo directory 
  to bring up the initial page. Restarted apache after the installation of the itasco demo and then clicked on the MapServ-demo link which brought up the initial demo page. 
  Clicked on initialize basic application and it worked like a charm.  The other selections
  worked as well. 
  Jeff, thank you for your help and patience on this!!!!!
  Not being familiar with what this is supposed to do.... and still learning this stuff, guess it was inevitable that I was doing something wrong.  Somewhere I read that all I had to do was double click on the file index.html to bring up the demo application...(maybe some old doc or applied to a different demo?) I did not understand that the demo application had to be installed directly into the directory structure of the MS4W directory tree.  That and the compounding problem that my UNZIP extracted to a newly created directory made things a little more confusing. 
  Couple Notes:  
  When I click on the mapserv-demo link the url displayed in IE is:  
  When I double click directly on c:/ms4w/apps/mapserv-demo/index.html 
  the resulting url displayed in IE is:  
  Either way the resulting page looks the same, but only when clicking on
  the mapserv-demo link does the demo work. I don't understand the significance
  of the difference in the resulting urls displayed by IE and why one method
  would work and the other does not.  If you have spent enought time on this, 
  then no need to explain now.  But very much apreciate the time you have
  spent putzing with this configuration problem via e-mail. Could the answer have
  something to do with apache being the web server and fetching the demo-page?  
  Best Regards, 
  John Rust
Jeff McKenna <jmckenna at dmsolutions.ca> wrote:
  I assume you are using the "MapServer demo" link on your localhost page 


> The results after clicking on: 
> c:/ms4w/apps/mapserv-demo/index.html
> and bringing up the initial demo page are as follows:
> Select - basic-application (click initialize)
> ---> Nothing happens. 
> Select - dhtml-add-rubber band box (click - initialize)
> ---> The controls appear but no map is displayed. 
> The windows alert box with the question about running
> c:/ms4w/apache/cgi-bin/mapserv.exe is ***not*** asked
> in either of the the two test cases mentioned above.
> Regards,
> - John Rust

Jeff McKenna
DM Solutions Group Inc.
ms4w-users mailing list
ms4w-users at lists.maptools.org

Do you Yahoo!?
 Next-gen email? Have it all with the  all-new Yahoo! Mail Beta.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maptools.org/pipermail/ms4w-users/attachments/20060710/a4d7507c/attachment.html

More information about the ms4w-users mailing list