[ms4w-users] Java Mapscript problem

Jesse Rosalia thejenix at gmail.com
Mon Nov 6 03:29:08 EST 2006

I am using MS4W v1.5.5 and Tomcat 5.5.9 (bundled with Netbeans 5.0), and Im
trying to use Java Mapscript within a web application.  I followed the
tutorial on the mapserver web site for setting up java mapscript with Tomcat
5.5, but cant seem to get around the following runtime error (occurs when it
tries to load the dll):

"java.lang.UnsatisfiedLinkError: C:\javamapscript\mapscript.dll: The
specified procedure could not be found"

I have mapscript.dll and supporting dlls (verified using the Microsoft
dependency walker utility) in the c:\javamapscript directory, and that
directory is in my system path.  I also installed mapscript.jar into the
tomcat common\lib directory.  I even tried compiling and running the
MapTest.java/MapThread.java tests distributed with the map server
source...still no dice.  I cant seem to figure out what Im doing wrong

Thanks in advance for your help

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maptools.org/pipermail/ms4w-users/attachments/20061106/527b9924/attachment.html

More information about the ms4w-users mailing list