[MS4W-Users] RV: Some problems installing ms4w Windows Server 2003 64 Bit [SOLVED]

David Alda Fernandez de Lezea dalda at ikt.es
Thu May 20 07:26:50 EST 2010

I'll answer myself because I've found the solution. There was an older installation of Oracle and in some way it interferred with the new one, so we cleaned up the OS and reinstalled the oracle client software and now it works perfect. For this case, I can say that it was not necessary to do what I mentioned in the previous email. Just install the oracle client and be aware that there isn't another oracle installation that may interfer.

Hope this can help to anyone.



Hello Jeff, 

For Oracle Spatial support, I hace few questions:

I've followed all the steps mentioned in ms4w documentation. I see "OCI driver" when I execute ogrinfo --formats, but whe I make a request to a Oracle Layer I get the typical error:

msOracleSpatialLayerOpen(): OracleSpatial error. Cannot create OCI Handlers. 
Connection failure. Check the connection string. Error: ORA-12154: TNS:could not resolve the connect identifier specified.

This is happening in a Server which is Windows Server 2008 64 Bit edition, but in my pc I've got the same configuration, and I'm a Win XP 32 bit edition. Do I have to set in httppd.conf some variables pointing to Oracle Directory? It's neccessary? And also, do I have to check wether Oracle directory is included in Path OS system variable or not?

In my machine I didn't specify anything in httpd.conf file about oracle installation and everything works perfectly.



-----Mensaje original-----
De: ms4w-users-bounces at lists.maptools.org [mailto:ms4w-users-bounces at lists.maptools.org] En nombre de Jeff McKenna Enviado el: miércoles, 19 de mayo de 2010 17:06
Para: ms4w-users at lists.maptools.org
Asunto: Re: [MS4W-Users] Some problems installing ms4w Windows Server 2003 64 Bit

David Alda Fernandez de Lezea wrote:
> Hello Jeff,
> Ms4w version 3.0.0 beta11 was unable to be installed. We tried out all 
> the mentioned steps but it didn't work except 'Test 5)', because the 
> verion we really wanted to be installed was beta10, so we installed
> VC++ package and Apache was installed succesfully.
> Thanks.

Then it seems there is a problem with the way Apache version 2.2.15 resolves your ServerName on that server.  You will hit that again when you upgrade Apache on that server, keep that in mind.


Jeff McKenna
MapServer Consulting and Training Services http://www.gatewaygeomatics.com/

MS4W-Users mailing list
MS4W-Users at lists.maptools.org

More information about the MS4W-Users mailing list