[MS4W-Users] Problems with PHP-Mapscript after upgrade

Ludwig Kniprath ludwig at kni-online.de
Mon Jul 18 11:26:05 EST 2011

Hi List,
I run Mapserver from the latest ms4w-package (ms4w_3.0.3) on Windows XP, 
Apache 2.2.19 with mod_fcgi 2.3.6, PHP 5.3.6.

I followed the installation docs "K. Installing the MS4W MapServer 
Binaries in Other Environments", because I just need the PHP-Mapscript 
in my Apache/PHP-Environment.

After Setup phpinfo() returns "MapServer version 6.0.1...", installation 
seems to be OK :-)

Problem 1 occurs in PHP when using print_r() on the Mapscript -Objects, 
because nothing is displayed.

$blank_map_object = new mapObj($map_file_path);

results to:

<snip>mapObj Object ( )</snip>

nothing more, no insight on properties.

But the map-object seems to be OK, because
writes the correct output.

Problem 2 occurs when setting a new projection to the above map-object:

$projection_obj = new projectionObj('+init=epsg:900913');
$blank_map_object->projection = $projection_obj;

In Mapserver 5.x everything worked as expected, but with MapServer 6 the 
above code just doesn't run, no exceptions, no errors, nothing in the 
error-log, just no reaction at all, the script stops.


I recognised some typos (?) in chapter k of the downloaded 
documentation, some of the listed dlls aren't included or with other 
versions ("aspell-15.dll" , "gdal17.dll", "gds32.dll"...)

More information about the MS4W-Users mailing list