[OSRS-PROJ] compile error on macos x

Glynn Clements glynn.clements at virgin.net
Wed Jul 17 02:06:25 EDT 2002

Alex Rice wrote:

> Howdy all, has anyone compiled PROJ.4 on Mac OS X?  I'm running 10.1.5...
> I ran into a little oddity and managed to fix the compile problem and 
> get the library installed, but have no idea why it was happening. I know 
> just enough C to get myself in trouble ;-).
> Below was the error in geod.c. This was the only compile error. The fix 
> I came up with was to
> reorder the includes in geod.c to the following. Anyone know why this 
> worked?

Note that a similar fix has recently been made to the CVS version.

Basically, the problem is that geodesic.h defines a number of very
short macros, some of them single characters:

	# define a	GEODESIC.A
	# define f	GEODESIC.FLAT

Any subsequent attempt to use any of these symbols in the wrong
context (e.g. as a type name, struct/union field etc) will result in
an error.

It appears that the ctype.h file on MacOS X uses one or more of these
symbols, resulting in an error; it's just luck that the problem hadn't
arisen on other platforms.

Glynn Clements <glynn.clements at virgin.net>
PROJ.4 Discussion List
See http://www.remotesensing.org/proj for subscription, unsubscription
and other information.

More information about the Proj mailing list