[Proj] -f arguments

Frank Warmerdam warmerdam at pobox.com
Wed Jul 21 09:38:07 EDT 2004

Marinos Charalampakis wrote:
> Unfortunately it doesn't work for me. I am using that :
> proj.exe -f "%.12f" -I +proj=utm +north +zone=34 +ellps=WGS84
> <pointsUTM.dat> pointsWGS84.dat
> and this is what i get:
> .12f .12f   -73.485
> .12f .12f   -73.443
> I also check without specifing any file but it is stil the same. I also use
> exactly your code and your numbers and I always get back what is in the ""
> after -f. Funny ah?

Marinos Charalampakis wrote:
 > I would also like to remind you that i run PROJ 4.4.6 for WIN32. I don't
 > know if this causes the problem...


My first thought was that the problem is that the DOS shell is interpreting the
'%' character to imply environment variable substitution.  However, I tried
it on windows, and it seemed to work fine for me.

D:\warmerda>proj.exe  -f "%.12f" -I +proj=utm +zone=34 +north +ellps=WGS84
100 300
16.512152010534 0.002705816086

This was with proj 4.4.8, but I looked through the cvs logs on the proj
mainline and I don't see any notes about changes that would seem to be
related.  So at this point I just don't know.  Perhaps try upgrading to
the latest.

Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Programmer for Rent

More information about the Proj mailing list