[Proj] Compiling in Cygwin: make error

Frank Warmerdam warmerdam at pobox.com
Wed Oct 25 00:04:32 EDT 2006

Martin du Saire wrote:
> Hi,
> I am trying to compile Proj4.5 in Cygwin2.5, but I think I am running 
> into problems with "make".
> configure doesn't report any errors, but when I run make, it seems to 
> get stuck on:
> if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. 
> -I. -I. -DPROJ_LIB=\"/usr/local/share/proj\"     -g -O2 -MT PJ_loxim.lo 
> -MD -MP -MF ".deps/PJ_loxim.Tpo" -c -o PJ_loxim.lo PJ_loxim.c; \
>     then mv -f ".deps/PJ_loxim.Tpo" ".deps/PJ_loxim.Plo"; else rm -f 
> ".deps/PJ_loxim.Tpo"; exit 1; fi
>  gcc -DHAVE_CONFIG_H -I. -I. -I. -DPROJ_LIB=\"/usr/local/share/proj\" -g 
> -O2 -MT PJ_loxim.lo -MD -MP -MF .deps/PJ_loxim.Tpo -c PJ_loxim.c  -DPIC 
> -o .libs/PJ_loxim.o
>  gcc -DHAVE_CONFIG_H -I. -I. -I. -DPROJ_LIB=\"/usr/local/share/proj\" -g 
> -O2 -MT PJ_loxim.lo -MD -MP -MF .deps/PJ_loxim.Tpo -c PJ_loxim.c -o 
> PJ_loxim.o >/dev/null 2>&1
> ad infinitum.  Is this normal, should I just let it run its course?


I just tried the proj 4.5.0 tar file on my cygwin and it built fine.
I am using a Cygwin for which uname reports a date of Jan10 2006.

Best regards,

I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | President OSGeo, http://osgeo.org

More information about the Proj mailing list