[Proj] msProcessProjection(): Projection library error. no system list, errno: 13

Adrian Popa adrian_gh.popa at romtelecom.ro
Tue Oct 13 05:52:09 EST 2009

Hello everyone!

I'm trying to troubleshoot a proj error, and I need your help! I have 
started this thread also on the mapserver mailing list, but I didn't 
find a solution yet: 

I'm running mapserver, and I'm trying to configure it to act as a WMS 
server. My data is in wgs84 (epsg:4326) and I want to project it to 
mercator projection (epsg:900913).

I have configured the mapfile and the projections according to the 
Mapserver documentation and they work as long as the projection sections 
are defined like:
    #spherical mercator/google
     "+proj=merc +a=6378137 +b=6378137 +lat_ts=0.0 +lon_0=0.0 +x_0=0.0 
+y_0=0 +k=1.0 +units=m +nadgrids=@null +no_defs"


    "+proj=longlat +ellps=WGS84 +datum=WGS84 +no_defs"

If I ask for EPSG projections (through WMS), I get the error in the subject.
Here is my WMS url:


I have tried to debug the problem by using shp2img, and it seems that 
mapserver tries to open /usr/share/proj/null as a file. I created a 
symlink between /usr/share/proj/epsg and /usr/share/proj/null, and now 
shp2img reads the file, but I get the same error while trying to call 
the WMS server.

My question is: how can I try to troubleshoot this issue - to see if 
there's a problem with proj?

I'd like to mention that I have added <900913> +proj=merc +a=6378137 
+b=6378137 +lat_ts=0.0 +lon_0=0.0 +x_0=0.0 +y_0=0 +k=1.0 +units=m 
+nadgrids=@null <mailto:+nadgrids=@null> +no_defs to my epsg file and my 
proj version is:
[adrianp at terra mapserver]$ rpm -qa | grep proj


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maptools.org/pipermail/proj/attachments/20091013/82fc0f62/attachment.htm 

More information about the Proj mailing list