[Shapelib] DBFReadStringAttribute broken?

Ian Wright ianw at graticule.com
Thu Mar 20 12:05:15 EDT 2008


Thanks for the reply. I have actually downloaded and tested that version 
now and the same problem
arises when using the lib/dll. I used the makefile to generate these and 
then tried replacing the ones that
I was currently using, and it has exactly the same problem.

So I tried including just the shapefil.h and dbfopen.c files as they 
were the only functions that I was
interested in within the project and thought stepping into these 
functions would help identify the
problem, however it ran fine right to the end. I've tried it a couple of 
times and as yet haven't had
the same problem or any corruption of variables whatsoever when running 
it just from those source

I'm not sure exactly what that suggests. Now that I've got it working in 
windows also I'm planning
not to use the DLL etc. and stick with what works for now, so I'm 
guessing if there haven't been
any other reported problems then it may not be worth worrying about?

If you do want to investigate further and theres anything I can be 
assistance of then let me know.

> Ian,
> I don't see why this is happening.  I would however suggest you update 
> to the
> current shapelib code.  There is code that is likely more recent in:
>   http://download.osgeo.org/shapelib/shapelib_1_2_10.zip
> However, I have also taken the liberty of packaging the latest 
> development
> code and posting it as:
>   http://download.osgeo.org/shapelib/shapelib-1.3.0a1.zip
> Try with updated code and see if the problem persists.   If it does, 
> then you
> should learn to use your debugger, build the dbfopen.c code with 
> debug, and
> step through the time "i" becomes corrupted to see what is going on.
> Best regards,

*Ian Wright*
/Software Developer
ianw at graticule.com /

* Graticule <http://www.graticule.com>
* 01132 344000

More information about the Shapelib mailing list