[TinyOWS-users] Problems with ms4w version

Joanne Cook j.cook at oxfordarch.co.uk
Mon Nov 15 09:57:43 EST 2010


Thanks for this. In answer to your question- I do have a http_tinyows.conf file, and the values in that seem correct. Unfortunately when I try the new version of tinyows that you have provided, I get no response when I run tinyows.exe --check. If I run from the browser I also don't get anything happening. In the apache logs I just get the error:
[Mon Nov 15 12:41:21 2010] [error] [client] Premature end of script headers: tinyows.exe

Dependency walker suggests a problem with MSVCR90.DLL

GetProcAddress(0x7C800000 [KERNEL32.DLL], "FlsAlloc") called from "MSVCR90.DLL" at address 0x78543ACC and returned NULL. Error: The specified procedure could not be found (127).
GetProcAddress(0x7C800000 [KERNEL32.DLL], "FlsGetValue") called from "MSVCR90.DLL" at address 0x78543AD9 and returned NULL. Error: The specified procedure could not be found (127).
GetProcAddress(0x7C800000 [KERNEL32.DLL], "FlsSetValue") called from "MSVCR90.DLL" at address 0x78543AE6 and returned NULL. Error: The specified procedure could not be found (127).
GetProcAddress(0x7C800000 [KERNEL32.DLL], "FlsFree") called from "MSVCR90.DLL" at address 0x78543AF3 and returned NULL. Error: The specified procedure could not be found (127).

I don't really know how to interpret this though, as I have that DLL in C:/windows/system32, and in ms4w/apps/tinyows.


----- Original Message -----
From: "Yewondwossen Assefa" <yassefa at dmsolutions.ca>
To: "Joanne Cook" <j.cook at oxfordarch.co.uk>
Cc: "TinyOWS users discuss list" <tinyows-users at lists.maptools.org>
Sent: Tuesday, 9 November, 2010 9:47:32 PM
Subject: Re: [TinyOWS-users] Problems with ms4w version


Using ma4w and apache, there should be an http_tinyows.conf file
installed in c:\ms4w\httpd.d . Do you have that file? It has 2 entries
should be available to Apache if you have restarted Apache after
installing tinyows. if you still have a problem, take these 2 lines and
stick them at the end of httpd.conf (c:/ms4w/Apache/conf/) and restart

As for new versions of tinypws, I usually put out ms4w compatible
versions when there is a tinyows release. I have put temporarily a
tinyows version ([1]) that I use locally. It uses the tinyows code out
of svn. It works for me with ms4w beta11. You can give it a try.

best regards,

[1]: http://www3.dmsolutions.ca/tmp/tinyows-svn-nov09-2010.zip

On 03/11/2010 7:38 AM, Joanne Cook wrote:
> Dear List,
> I have recently installed tinyows in ms4w (3.0 beta) on both Windows
> XP SP3 and Windows Server 2008 R2, but I'm having a few problems
> getting it working.
> My config is as follows:
> <tinyows online_resource=""
> 	 schema_dir="C:\ms4w\apps\tinyows\schema">
>    <pg host="***.***.***.***" user="***" password="***" dbname="***"
>    port="***"/>
>    <contact name="Test TinyOWS Server"
>      	   site=""
>     	   email="admin at localhost" />
>    <layer retrievable="1"
> 	 prefix="test" server=""
>           name="testlayer" title="Test layer" />
> </tinyows>
> I have confirmed that my database configuration is correct and working
> with ogrinfo and that the user has all the correct permissions. When I
> try and test tinyows at the command line, it closes with a generic
> windows error. The apache logs show the following, which I have seen
> discussed in a different mail to the list:
> This application has requested the Runtime to terminate it in an
> unusual way.
> [Wed Nov 03 11:22:17 2010] [error] [client] Please contact
> the application's support team for more information.\r
> [Wed Nov 03 11:22:17 2010] [error] [client] File does not
> exist: C:/ms4w/Apache/htdocs/favicon.ico
> [Wed Nov 03 11:22:38 2010] [error] [client] Premature end of
> script headers: tinyows.exe
> [Wed Nov 03 11:22:38 2010] [error] [client] Assertion
> failed: !o->exit, file src\\ows\\ows_error.c, line 77\r
> I notice that when this happens, the config information shows up as
> @prefix@/ms4w/apps/tinyows/config.xml- which implies it's not picking
> up the drive letter correctly. If I set the TINYOWS_CONFIG_FILE and
> TINYOWS_SCHEMA_DIR environment variables in windows then tinyows
> --check works- up to a point!
> My layer should be in EPSG 27700, but shows up in tinyows as an SRID
> of -1. If I add the srid to the layer config then this is not picked
> up. When I try to run
> then I get the same generic windows error as above, and the same error
> in the apache error log.
> I don't have access to any windows compilation tools, so am unable to
> try the svn version to see if this problem still occurs. Can anyone
> help me?
> Thanks
> Jo

---------------------------------------------------------------- Assefa
Yewondwossen Software Analyst

Email: yassefa at dmsolutions.ca

Phone: (613) 565-5056 (ext 14)
Fax: (613) 565-0925

Joanne Cook
Senior IT Support and Development
Oxford Archaeology (North)
01524 880212

Files attached to this email may be in ISO 26300 format (OASIS Open Document Format). If you have difficulty opening them, please visit http://iso26300.info for more information.

More information about the TinyOWS-users mailing list