[Chameleon-dev] [Bug 1193] New: LayerAttributes: change
getWFSResource into getOWSResource
bugzilla-daemon at bugzilla.maptools.org
bugzilla-daemon at bugzilla.maptools.org
Fri Nov 4 08:33:36 EST 2005
http://bugzilla.maptools.org/show_bug.cgi?id=1193
Summary: LayerAttributes: change getWFSResource into
getOWSResource
Product: Chameleon
Version: 2.2
Platform: PC
OS/Version: Windows XP
Status: NEW
Severity: normal
Priority: P2
Component: Core
AssignedTo: chameleon-dev at lists.maptools.org
ReportedBy: bartvde at xs4all.nl
Currently I am developing a widget which needs to check the DescribeLayer
response. LayerAttributes.php has some functions for this.
But for my situation I need to check if the layer is vector or raster, so I also
need to check if the DescribeLayer returns a WFS or a WCS. If WCS, I need the
OnlineResource just like is done for WFS.
I propose to rename getWFSResource into getOWSResource and add the following to
support WCS:
if ( strtolower( $aVals[$i]['tag'] ) == 'layerdescription' &&
isset( $aVals[$i]['attributes']['wfs'] ) )
{
$aszReturn['wfs'] = $aVals[$i]['attributes']['wfs'];
}
if ( strtolower( $aVals[$i]['tag'] ) == 'layerdescription' &&
isset( $aVals[$i]['attributes']['wcs'] ) )
{
$aszReturn['wcs'] = $aVals[$i]['attributes']['wcs'];
}
For backward compatibility we could keep a getWFSResource function in there
which just calls getOWSResource.
Thoughts? Objections?
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
Please do NOT reply to this email, use the link above instead to
login to bugzilla and submit your comment. Any email reply to this
address will be lost.
More information about the Chameleon-dev
mailing list