[Chameleon] Trouble with zooming

Paul Spencer pspencer at dmsolutions.ca
Tue Nov 9 08:36:37 EST 2004


Tyler Mitchell wrote:
>>I just tried this.  I do note that the legend template is failing to
>>load for some reason, this normally indicates an incorrect path ;)
> Do you mean in cwc2.xml and chameleon.xml config files?  Or could paths 
> elsewhere be a problem?

actually I meant in the widget, but you seem to have fixed it :)

>>Zooming appears to work for me, although I am on dial up and the map
>>seems to be erratic ... the scale bar is updating correctly, as are the
>>latitude and longitude.  
> No way.  I won't believe it :)  Is there a session stored somewhere I should 
> toast to make it work for me?
>>Can you tell me what browser you are using? 
>>Note that Chameleon only really works reliably in IE and netscape 6+
>>right now (although I have reports of Safari working reasonably well,
>>and Opera also seems to work except for the wait image not going away).
> Well,  I've tried it on Mozilla 1.6 (~= netscape 5?), Mozilla Firefox 0.9.3 
> and in KDE's Konqueror browser.  My app didn't work in either of them.  
> HOWEVER, it looks to be a problem with my template, since if I use another 
> template (sample_cwc2.html) it works okay with my context:
> http://spatialguru.com/cwc2/cwc2.php?service=VCG&request=GetApplication&version=0.1.0&LANGUAGES=en-CA&TEMPLATES=sample_cwc2.html&CONTEXTS=world_context.xml
> Note world_context.xml is my own creation, but seems to work okay with the 
> sample template.  Although I get this error when zooming in: 
> "maturity_level not found. Returning default value." (I'll try not to take it 
> personally)  But the map draws fine.

I think you found this problem already

>>To help debugging, you can change your form to method="GET" and then you
>>can see the URL that is being requested when the page submits, this
>>might help me also ...
> On the original one (which I'll kindly set aside now :)  I changed method to 
> "GET" and now I see the details.  Nothing stands out as a problem there to 
> me.

the GET method actually seems to break cwc2, I think I know why.  It 
seems that the service, version and request parameters are not being 
propogated to the next page.  For the moment, you can work around this 
by adding

<input type="hidden" name="service" value="VCG">
<input type="hidden" name="version" value="0.1.0">
<input type="hidden" name="request" value="GetApplication">

> Thanks for helping me find my legs.

no problem :)  Can you send me your template (or give me the URL to it?)

> Tyler
>>Tyler Mitchell wrote:
>>>Hi again,
>>>I've got a basic app started, but can't seem to be able to zoom in.  The
>>>initial map shows but if I zoom in I don't get anything.  I'm wondering
>>>what I've done wrong.
>>>My mega long URL is:
>>>Any ideas?
>>>Chameleon mailing list
>>>Chameleon at lists.maptools.org



|Paul Spencer                           pspencer at dmsolutions.ca   |
|Applications & Software Development                              |
|DM Solutions Group Inc                 http://www.dmsolutions.ca/|

More information about the Chameleon mailing list