[Chameleon] Installing Chameleon on FC4 - fixed with PHP 5.0.5 (?)

Paul Spencer pspencer at dmsolutions.ca
Fri Dec 23 08:44:38 EST 2005


some folks got Chameleon working with an earlier PHP 5.0.x so I  
suspect it was something specific to either PHP 5.0.4 or php- 
mmcache.  This wouldn't be the first time that a specific PHP version  
gave us trouble :)



On 23-Dec-05, at 1:44 AM, Mike Leahy wrote:

> List,
> It seems my problem was solved when I updated to PHP 5.0.5 today.   
> After a fair bit of tinkering, I had left this installation alone.   
> Today's updates for FC4 included PHP 5.0.5, for which I removed php- 
> mmcache, which was dependent on PHP 5.0.4 and hadn't been updated.   
> After doing so, I thought I'd give Chameleon a try again, and it  
> simply worked without changing the problematic configuration I had  
> last week.
> Prior to today, I have run various other updates on my system, and  
> have rebooted once or twice, but I don't think I have done anything  
> that should affect the web server, PHP or Chameleon.  So either I  
> just got lucky with some accidental tinkering or configuration  
> changes that I left unchecked last week, or Chameleon requires PHP  
> 5.0.5+, or php-mmcache caused some other problem I'm unaware of  
> (I'm not sure if it was even being used by PHP).  Are there any  
> experts that might know if the latter two possibilities would have  
> caused my problem?
> Thanks again for any response,
> Mike
> Mike Leahy wrote:
>> Hello again,
>> I think I'm getting to the bottom of this...sort-of.  At least, I  
>> think I know where the problem is occurring.  In the chameleon  
>> class (chameleon.php), the HttpFormVars objects is created to  
>> store whatever get/post parameters are passed to the page.  It  
>> works fine in the constructor function, and I can execute "$this- 
>> >moHttpFormVars->isVarSet('SID')", which returns false (as it  
>> should on a fresh load with no session id).  In the initial sample  
>> script, I can also access $oApp->moHttpFormVars from the initial  
>> application script (e.g., sample_enhanced.phtml).  However, when  
>> the CWCInitialize(), $this->moHttpFormVars->isVarSet on line 447  
>> claims to be a non-object.
>> I'm guessing this is a problem with my PHP configuration (as that  
>> was the source of my 'blank screen' installation problems on  
>> windows), and I'm wondering if maybe Chameleon has issues running  
>> in PHP 5.  What's more, whenever I run chameleon twice, all of the  
>> scripts that deal with the Chameleon object (i.e. $oApp) stop  
>> working until I edit the php files again...restarting the server  
>> and/or the browser doesn't seem to make anything reload again,  
>> only changing the content of the php scripts.  Has anyone had this  
>> sort of experience with Chameleon, or maybe just PHP in general?
>> Regards,
>> Mike
>> However, in the CWCInitialize() function,
>> Mike Leahy wrote:
>>> Hello again,
>>> I'm not sure whether this adds any insight into this problem, but  
>>> if I try to load the Chameleon admin page, I get yet another  
>>> blank page, and the following error logged in the httpd error_log  
>>> file:
>>> [23389] MMCACHE can't restore parent class "logger" of class  
>>> "AppContext"
>>> [Thu Dec 15 18:43:36 2005] [notice] child pid 23389 exit signal  
>>> Segmentation fault (11)
>>> Anyone have some ideas?
>>> Mike
>>> Mike Leahy wrote:
>>>> Hello list,
>>>> I'm trying to see if I can get our applications running in a Linux
>>>> environment.  I've got everything setup on FC4, with apache  
>>>> 2.0.54, PHP
>>>> 5.0.4, MapServer 4.8.0-beta2, PHP/MapScript (this module loads fine
>>>> in-line in PHP using dl function, but fails if included in the PHP
>>>> startup - has anyone else had a similar problem?).
>>>> Here's the result of ms_GetVersion() after I dl() the mapscript  
>>>> module
>>>> in a PHP test script:
>>>> MapServer version 4.8.0-beta2 OUTPUT=GIF OUTPUT=PNG OUTPUT=JPEG
>>>> I've most recently tried setting up chameleon, and I'm fairly  
>>>> sure I've
>>>> got the chameleon.xml and cwc2.xml configuration files setup  
>>>> properly,
>>>> but I'm getting a blank page when I try to load one of the  
>>>> Chameleon
>>>> samples.  I know the sample mapfile "chameleon.map" works fine,  
>>>> as I can
>>>> load it directly though the mapserver cgi-bin executable as a  
>>>> WMS.  I
>>>> also have been able to determine that the startup sample scripts  
>>>> end
>>>> when the $oApp->CWCInitialize() function is executed. In the httpd
>>>> error_log file, the only notice of a problem I get is as follows:
>>>> [client] PHP Warning:  Invalid argument supplied for  
>>>> foreach()
>>>> in /var/www/chameleon/htdocs/common/appcontext/appcontext.php on  
>>>> line 276
>>>> the corresponding code in appcontext.php is:
>>>> foreach ($this->aoContext as $oContext)
>>>> {
>>>>   $result = $oContext->getContextValue( $szParam );
>>>>   if ($result !== false)
>>>>   break;
>>>> }
>>>> I've had similar 'blank page' issues when installing Chameleon in
>>>> windows.  I've also noticed many other users run into this, and it
>>>> usually relates to some configuration issue.  However, I'm at a  
>>>> bit of a
>>>> loss with this in my FC4 configuration.  Has anyone got a clue what
>>>> settings/requirements in PHP, Apache, or Chameleon that I have  
>>>> overlooked?
>>>> As an aside, does anyone know why this error doesn't get  
>>>> reported to the
>>>> page in the browser?  If I put an intentional syntax error, it  
>>>> appears
>>>> as normal in the browser...
>>>> Thanks in advance for any help,
>>>> Mike
>>>> _______________________________________________
>>>> Chameleon mailing list
>>>> Chameleon at lists.maptools.org
>>>> http://lists.maptools.org/mailman/listinfo/chameleon
>>> _______________________________________________
>>> Chameleon mailing list
>>> Chameleon at lists.maptools.org
>>> http://lists.maptools.org/mailman/listinfo/chameleon
>> _______________________________________________
>> Chameleon mailing list
>> Chameleon at lists.maptools.org
>> http://lists.maptools.org/mailman/listinfo/chameleon
> _______________________________________________
> Chameleon mailing list
> Chameleon at lists.maptools.org
> http://lists.maptools.org/mailman/listinfo/chameleon

|Paul Spencer                           pspencer at dmsolutions.ca   |
|Applications & Software Development                              |
|DM Solutions Group Inc                 http://www.dmsolutions.ca/|

More information about the Chameleon mailing list