[Chameleon] oops ...

Sears, Jeremy Jeremy.Sears at CCRS.NRCan.gc.ca
Fri Jan 6 10:25:56 EST 2006

Hi All,

Im running chameleon with MS4W on WinXP. In an attempt to upgrade the
version of PHP that ships with MS4W I seemed to have damaged chameleon. I
went thru the motions of upgrading PHP successfully. When finished I
realized that the PHP upgrade was not what I needed to do.. so I attempted
to restore the ms4w dir to its state before the PHP upgrade. I did this by
copying a back-up version of my MS4W dir over the modified MS4W. So..
everything should be exactly the same as it was in the MS4W dir before I
modified it. Chameleon worked fine before the modification. Now when I look
at my mapserver app I get the following error:

Warning: dl(): Unable to load dynamic library
'/ms4w/Apache/php/extensions/php_mapscript_44.dll' - The specified module
could not be found. in D:\ms4w\apps\chameleon\htdocs\chameleon.php on line

Fatal error: Call to undefined function: ms_reseterrorlist() in
D:\ms4w\apps\chameleon\htdocs\chameleon.php on line 627

I suspected that there may be some sort of permissions issue as the file
'/ms4w/Apache/php/extensions/php_mapscript_44.dll' exists. However after
changing the permissions, I am still receiving the same error.

What could have changed between my original MS4W installation and the
backed-up MS4W? Besides re-installing MS4W and setting up my app again what
can I do to make Chameleon work?

Many Thanks

More information about the Chameleon mailing list