FW: [Chameleon] CwcImage_0 when upgrading to Chameleon 2.6

john lace johnlace65 at hotmail.com
Tue Sep 2 15:51:01 EDT 2008

Dear Justin:No, it wasn't your fault.   I didn't explain my findings correctly.   The hover doesn't work, and the right click will point (when on a cwcimage_0) to the original button location ../skins/sample.., not to the ms_tmp copy, in firefox;   and it points to the sample_basic.phtml, in internetExplorer.  I think that I understand the basic ms_tmp process.  Chameleon and MapServer write to a file path, so we need to configure the button_cache_path (for buttons) and the tmp_img_path (for scale and other images).   And Apache needs a url, so we need the corresponding button_cache_web_path and the tmp_web_path.  I've tried modifying these, and the images path work well, but not the buttons config.   I discover that in ie the tmp buttons get created only when you exit ie and reenter.  That's why I didn't notice buttons written there before.  I even moved the full ms_tmp to avoid possible conflicts with symlinks.   I've tried something else.  Forgetting linux for a while,  I installed ms4w on a new winXP computer, with Chameleon24ms4w.  I only changed the mapscript_module config to point to  php_mapscript_44.dll (or _46.dlls, same result).  The sample_basic.phtml works Ok.   But as soon as I install Chameleon26ms4w, the same cwcimage_0 text, all over the page.    All were downloaded today from www.maptools.org Do you think that we need to file this as a bug? Thanks for your reply John Lace.  

From: justin.ngan at utoronto.caTo: johnlace65 at hotmail.comSubject: RE: [Chameleon] CwcImage_0 when upgrading to Chameleon 2.6Date: Mon, 1 Sep 2008 23:18:23 -0400

Alright, my fault for being too verbose in the last e-mail. J  The hover won’t work as you’ve discovered BUT, what if you RIGHT-click where you are expecting an icon/image and then click Properties in the context menu of the browser. You should get a properties page that shows you where and what the file location should be. I’ve attached an image of what I mean.  Sometimes, a picture really is worth a thousand words.


From: chameleon-bounces at lists.maptools.org [mailto:chameleon-bounces at lists.maptools.org] On Behalf Of john laceSent: Monday, September 01, 2008 10:15 PMTo: chameleon at lists.maptools.orgSubject: FW: [Chameleon] CwcImage_0 when upgrading to Chameleon 2.6
Thanks again for your reply, Justin. But it hasn't solved my problem.hovering or right clicking on the "cwcimage_0" text will only point to the sample_basic.phtml# file, and not to the expected button image, as it does for the scale bar and other images. Maybe the explanation (and solution) comes from the fact that in my actual configuration I have never seen buttons created to the /ms_tmp/buttons/ folder, and that was unimportant for ver 2.4 but now it's crucial for 2.6.    Something related to the skins/  file config?    The sample files are identical for 2.4/2.6, and the directories below chameleon are also just the same. What else could I check?   writing rights, paths and main.phtml I have checked several times. Thanks for your replyJohn Lace  

From: justin.ngan at utoronto.caTo: johnlace65 at hotmail.comSubject: RE: [Chameleon] CwcImage_0 when upgrading to Chameleon 2.6Date: Mon, 1 Sep 2008 15:00:21 -0400

Out of curiosity, if you right click on where the icon is expected, and click on properties (sometimes a hover is enough), does it show you where it is looking for the image? This has been a very useful way for us to trouble porting and setup problems!
 After that, I would look in that location, after the map is loaded (don’t close the session of course) and see if the image is there.
 If it is: then there is a rights issue between chameleon/mapserver/apache. 
If it is not: are you developing in an environment that offers a ‘file search’ tool and see if you can locate where the ‘expected file’ is being placed?
Finally, if the search does not return any file of the name expected, then almost for sure, you know that you have a rights problem for ‘writing’. 
Incidentally, after looking at your config file, I know that it looks just the way it SHOULD according to chameleon docs. HOWEVER, I think that in the more recent versions, the *_tmp locations are definitely an issue. I bet, your problem can be fixed by following the above suggestions and finding which temp directory Chameleon is dropping your images. GOOD LUCK! 
I hope this helps a little.
Get Windows Live and get whatever you need, wherever you are.  Start here.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maptools.org/pipermail/chameleon/attachments/20080902/b3310bdf/attachment.html

More information about the Chameleon mailing list