[FGS] phplib doesn't work

Guillaume Dallaire gdallaire at mapgears.com
Mon Apr 24 14:29:18 EDT 2006

On Fri, 2006-04-21 at 17:12 -0700, Eric Shuman wrote:
> I am having a problem getting the pdflib to work.
> I have run through the fgs install of pdflib_lite base (6.0.2) and
> php_pdf-module (4.4.2) and everything seemed to go OK.  When I try to make a
> pdf in PHP I get an error when trying to call pdf_new(). So I checked the
> phpinfo() and there is no entry for PDF.  If I try to use the lib as an
> extension in php.ini I get this error "Unable to load dynamic library
> '/GIS/fgs/www/lib/php4/pdf.so' - /GIS/fgs/www/lib/php4/pdf.so: undefined
> symbol: PDF_open_fp in ..." If I try to use the dl() call in my script I get
> the same error.
> I had a previous setup using Fedora Core3 and everything worked fine.  Now I
> am using Debian "Sarge".  Could that be the problem?? Or has something
> changed in the modules?  Anyone else having this problem?  Suggestions?

Hi Eric,

Your PHP binary has a problem to load the pdf.so module. I think this is
related to a problem with a specific php build.

try to update your php-base module:

$ fgs force-update fgs-base:4.4.2

Please report if it fixes your problem, and from what self-extracting
file version you installed your FGS.


Guillaume DALLAIRE     gdallaire at mapgears.com
     Mapgears             www.mapgears.com

More information about the Foss-gis-suite mailing list