[FGS] phplib doesn't work

Eric Shuman erics at ameri-title.com
Fri Apr 21 20:12:29 EDT 2006

I am having a problem getting the pdflib to work.

I have run through the fgs install of pdflib_lite base (6.0.2) and
php_pdf-module (4.4.2) and everything seemed to go OK.  When I try to make a
pdf in PHP I get an error when trying to call pdf_new(). So I checked the
phpinfo() and there is no entry for PDF.  If I try to use the lib as an
extension in php.ini I get this error "Unable to load dynamic library
'/GIS/fgs/www/lib/php4/pdf.so' - /GIS/fgs/www/lib/php4/pdf.so: undefined
symbol: PDF_open_fp in ..." If I try to use the dl() call in my script I get
the same error.

I had a previous setup using Fedora Core3 and everything worked fine.  Now I
am using Debian "Sarge".  Could that be the problem?? Or has something
changed in the modules?  Anyone else having this problem?  Suggestions?

Eric Shuman

15 Oregon Ave
Bend, OR 97701
(541) 617-6497
erics at ameri-title.com

More information about the Foss-gis-suite mailing list