[FGS] Starting apache error: httpd cannot execute binary file

Hao Zhang hao at zhang.nu
Fri Nov 6 08:07:37 EST 2009

Hi Norm,

Sorry for my late feedback. The day before yesterday, I finally built FGS
self-installer from source successfully (with name
"fgs-mapserver_basic_5.2.1-1.0.1-linux-sparc64.bin"). Thank you very much
for your help all the time.

However, I don't think the last error "Conflicting version ..." has anything
to do with other module/lib uses another version of curl somewhere. The
outcome of running "fgsdev dump_modules_for_dep curl-lib mapserver-php" is:
Actual version of the target dependency:  curl-lib:7.19.4
gdal-base curl-lib:7.19.4
mapserver-php curl-lib:7.19.4

The cause of the error is that in the list of modules I provide in command
"build_si" contain several modules that depend on the same module, e.g.
"apache_mod_ssl-module" "gdal-base" both depend on curl-lib. If I give them
three in an order such as "fgsdev list_modules_dep apache_mod_ssl-module
curl-lib gdal-base", it will reproduce the same error. I found out this is
related to the behavior of function 'get_dep' in script
fgs-dev/bin/lib/list_module_dep.sh. In this function, it will loop call
itself in order to get all depended modules for the given module as well as
all its required modules in required.list. This behavior will in some case
cause line "if [ "`grep ^$dep_name: $LIST_FILE`" != "$dep" ] ; then" return
true and exit with "! Conflicting version ...". After function 'get_dep'
goes through "apache_mod_ssl-module" and "curl-lib", there will be two
duplicated lines 'curl-lib:7.19.4' in the $LIST_FILE. Thus, when function
'get_dep'  works on "gdal-base", line "if [ "`grep ^$dep_name: $LIST_FILE`"
!= "$dep" ] ; then" returns true and exit. However, the order of module list
also matters, e.g. "fgsdev list_modules_dep curl-lib apache_mod_ssl-module
gdal-base" will work well.

So I changed list of modules I provide in command "build_si" to avoid
multiple dependances among them but cover all necessary modules for
installer. Then it successfully built the self-installer. Command I run
looks like:
fgsdev build_si mapserver_basic_5.2.1 1.0.1 mapserver-base mapserver-php
apache_mod_ssl-module freetds-lib gdal_python-module gettext-base
libxslt-lib ming-lib postgis-lib postgresql-server python_mapscript-module
sablotron-base php_curl-module php_ftp-module php_gettext-module
php_mssql-module php_odbc-module php_ogr-module php_pgsql-module
php_wddx-module php_xmlrpc-module php_xsl-module


On Wed, Nov 4, 2009 at 4:12 PM, Normand Savard <nsavard at mapgears.com> wrote:

> Hao Zhang wrote:
>> Outcome:
>> * Creating archive file containing all required FGS modules...
>> + Including base module... ok
>> ! Conflicting version for 'curl-lib': Another(s) package(s) request(s)
>> '7.19.4
>> 7.19.4'
>> ! and 'gdal-base' requests '7.19.4', aborting.
>> ! /home/FGS/fgs-dev/bin/fgsdev: Fatal error returned, exiting...
>> * Creating self-extracting archive script
>> * Self installer image created with success in
>> '/home/FGS/fgs-dev/modules/fgs-mapserver_basic_5.2.1-1.0.1-linux-sparc64.bin'.
>> * Versions info file is
>> '/home/FGS/fgs-dev/modules/fgs-mapserver_basic_5.2.1-1.0.1-linux-sparc64.versions'.
>> But the built curl-lib version is 7.19.4
>> (fgs-curl-lib-7.19.4-linux-sparc64.tar.gz), why will it still complain?
>>  Hao,
> There is a module/lib or other that uses another version of curl somewhere.
>  Try:
> fgsdev dump_modules_for_dep curl-lib mapserver-php
> Norm
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maptools.org/pipermail/foss-gis-suite/attachments/20091106/fc368ba3/attachment.htm 

More information about the Foss-gis-suite mailing list