[FWTools] MODIS processing

Frank Warmerdam warmerdam at pobox.com
Wed Jan 4 11:13:33 EST 2006

On 1/4/06, Ned Horning <nedh at lightlink.com> wrote:
> Frank,
> Thanks for the quick reply. I pasted the output from gdalinfo below. I don't
> see any evidence that GCPs are used from the gdalinfo output. That said, I
> have a feeling that OpenEV is using GCPs since I'm not sure how else
> georeferencing could work.
> I tried to run gdalinfo on one of the subdatasets (# 6) but there seems to
> be a problem with my input file syntax. This is one version I tried:
> gdalinfo
> HDF4_EOS:EOS_SWATH:"C:\AMNH\ModisCloudImages\MOD35_L2.A2000184.0755.005.2005
> 182222430.hdf":mod35:Cloud_Mask
> I will try gdalwarp as you suggest but first I need figure out how to
> specify the first band of subdataset 6 as input into gdalwarp. Can you help
> with that?


The GCPs would only show up when you do the gdalinfo on the subdataset.
I am not sure why you are running into problems with gdalinfo on the subdataset
name, likely some sort of shell processing issue.

You might want to try changing the backslashes to forward slashes, and/or
removing the double quotes.  You might also find you need to add
single or double quotes around the whole thing.

... ahh, now that I look at it, the problem is likely the colon after
the drive letter.  If you don't need it (ie. you are already on c:)
then just drop the drive specification.  Otherwise, you *will* need the
double quotes around that portion of the name, but you will need to
protect them from processing by the shell.  Perhaps this can be
accomplished by prefixing them with backslashes.

I realize this is all pretty messy.

Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Programmer for Rent

More information about the FWTools mailing list