[FWTools] MODIS processing

Ned Horning nedh at lightlink.com
Wed Jan 4 12:25:36 EST 2006


Thanks, that did the trick. I deleted "C:" and gdalinfo works fine on the
subdataset. It appears that there is a GCP for every pixel. When I ran
gdalwarp I also realized I needed to use double-quotes instead of single

When I run gdalwarp I get the following error: 

A target coordinate system was specified, but there is no source coordinate
system.  Consider using -s_srs option to provide a source coordinate system.
Operation terminated.

My input was:
C:\Program Files\FWTools1.0.0a7>gdalwarp -t_srs "+proj=utm +zone=38
222430.hdf:mod35:Cloud_Mask modis_cloud.tif

Any thoughts?

Also, is it possible to select a single band from the HDF subdataset for
gdalwarp? I didn't see a band selection switch. 

All the best, 


> Ned,
> The GCPs would only show up when you do the gdalinfo on the subdataset.
> I am not sure why you are running into problems with gdalinfo on the
> name, likely some sort of shell processing issue.
> You might want to try changing the backslashes to forward slashes, and/or
> removing the double quotes.  You might also find you need to add
> single or double quotes around the whole thing.
> ... ahh, now that I look at it, the problem is likely the colon after
> the drive letter.  If you don't need it (ie. you are already on c:)
> then just drop the drive specification.  Otherwise, you *will* need the
> double quotes around that portion of the name, but you will need to
> protect them from processing by the shell.  Perhaps this can be
> accomplished by prefixing them with backslashes.
> I realize this is all pretty messy.
> Best regards,
> --
> I set the clouds in motion - turn up   | Frank Warmerdam,
warmerdam at pobox.com
> light and sound - activate the windows | http://pobox.com/~warmerdam
> and watch the world go round - Rush    | Geospatial Programmer for Rent

More information about the FWTools mailing list