[FWTools] MODIS processing

Frank Warmerdam warmerdam at pobox.com
Wed Jan 4 13:13:39 EST 2006

On 1/4/06, Ned Horning <nedh at lightlink.com> wrote:
> Frank,
> Thanks, that did the trick. I deleted "C:" and gdalinfo works fine on the
> subdataset. It appears that there is a GCP for every pixel. When I ran
> gdalwarp I also realized I needed to use double-quotes instead of single
> quotes.
> When I run gdalwarp I get the following error:
> A target coordinate system was specified, but there is no source coordinate
> system.  Consider using -s_srs option to provide a source coordinate system.
> Operation terminated.


Normally the GCPs would be marked as WGS84, and that would
establish the source coordinate system.  I wonder if something
might be broken.  Can you make the modis dataset in question
available for me to grab and try?

You could add "-s_srs WGS84" to the commandline but I suspect
there is something more wrong.

> My input was:
> C:\Program Files\FWTools1.0.0a7>gdalwarp -t_srs "+proj=utm +zone=38
> +datum=WGS84"
> HDF4_EOS:EOS_SWATH:\AMNH\ModisCloudImages\MOD35_L2.A2000184.0755.005.2005182
> 222430.hdf:mod35:Cloud_Mask modis_cloud.tif
> Any thoughts?
> Also, is it possible to select a single band from the HDF subdataset for
> gdalwarp? I didn't see a band selection switch.

It seems that gdalwarp does not offer an option for this.
You could try and subset the bands before warping, or
after, using gdal_translate.  It would likely be better to do
it afterwards, and GeoTIFF format is unlikely to hold the
number GCPs in the MODIS dataset.

Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Programmer for Rent

More information about the FWTools mailing list