[FWTools] gdalwarp reprojecting to PCIDSK

Wim Chalmet wim.chalmet at terraengine.com
Mon Jan 15 15:28:20 EST 2007

I have come accross an issue reprojecting to PCIDSK using gdalwarp. It works
excellent, up to a certain file size. The cut-off seems to be somewhere
between 2 and 3 GB.
I am currently trying to reproject 8bit data single band to a UTM
projection. My source image is about 2.6GB, and the reprojected image turns
out to be about 3.8GB. I have tried another image where the source is 2.4GB
and the reprojected image is 3.5 GB, and here all was fine.
When I open the reprojected problem pix in PIC, I get the following error:
"warning: test.pix file header uses a block value larger than 2147483647.
File cannot be correctly read."
The image part gets reprojected fine, but somehow, when checking the
resulting .pix file in PCI, it does not contain the projection information
anymore (PCI reports a "pixel" projection).
I have upgraded to fwtools 1.1.3, but with the same result.
Is this a bug in the pcidsk driver? I can make demo data available if needed
to try this out.
Yours truly,
Wim Chalmet

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maptools.org/pipermail/fwtools/attachments/20070115/7091f0be/attachment.html

More information about the FWTools mailing list