[FWTools] gdalwarp reprojecting to PCIDSK

Frank Warmerdam warmerdam at pobox.com
Mon Jan 15 17:51:46 EST 2007

Wim Chalmet wrote:
> Hi,
> I have come accross an issue reprojecting to PCIDSK using gdalwarp. It 
> works excellent, up to a certain file size. The cut-off seems to be 
> somewhere between 2 and 3 GB.
> I am currently trying to reproject 8bit data single band to a UTM 
> projection. My source image is about 2.6GB, and the reprojected image 
> turns out to be about 3.8GB. I have tried another image where the source 
> is 2.4GB and the reprojected image is 3.5 GB, and here all was fine.
> When I open the reprojected problem pix in PIC, I get the following 
> error: "warning: test.pix file header uses a block value larger than 
> 2147483647. File cannot be correctly read."
> The image part gets reprojected fine, but somehow, when checking the 
> resulting .pix file in PCI, it does not contain the projection 
> information anymore (PCI reports a "pixel" projection).
> I have upgraded to fwtools 1.1.3, but with the same result.
> Is this a bug in the pcidsk driver? I can make demo data available if 
> needed to try this out.


A serious bug was discovered late last week in the PCIDSK driver with
files larger than about 250MB (well it really depends on a few
configuration factors).  It has been fixed but there the bug is in
GDAL 1.4.0, and in all FWTools releases.  Once an FWTools 1.1.4 is
cut it should have the fix, but I have no specific timeline for that.


Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | President OSGeo, http://osgeo.org

More information about the FWTools mailing list