[FWTools] libtiff assertion failure

Matthew Williamson Matt.Williamson at noaa.gov
Tue Jul 8 15:56:07 EDT 2008

Hello all,

Having an annoying problem with Linux FWTools. I have some GeoTIFFs  
that I'm trying to use with MapServer's shp2img, but it dies with the  
following error:

tif_dirread.c:4670: TIFFFetchNormalTag: Assertion `0' failed.

Actually, opening the file in OpenEV or even running gdalinfo on the  
file produces the same error, and the program dies.

Interestingly, I ran gdalinfo.exe from the Windows version of FWTools,  
and it worked fine, but gave the following warning:

Warning 1: TIFFFetchNormalTag:ASCII value for tag "Software" does not  
end in null byte

...so I'm guessing this is what's causing the problem under Linux. The  
files were created by jNexradExplorer, so I'll email the author to see  
if he can fix it at that end. But is it possible to have the tools  
warn instead of die on this error? Or, is there something I can do to  
fix the files as a workaround (a way to strip or rewrite the  
"Software" tag, perhaps)? This is all part of a scripted batch job, so  
I'd need to be able to repeat it from a script.



More information about the FWTools mailing list