[FWTools] libtiff assertion failure

Frank Warmerdam warmerdam at pobox.com
Tue Jul 8 16:18:38 EDT 2008

Matthew Williamson wrote:
> Hello all,
> Having an annoying problem with Linux FWTools. I have some GeoTIFFs that 
> I'm trying to use with MapServer's shp2img, but it dies with the 
> following error:
> tif_dirread.c:4670: TIFFFetchNormalTag: Assertion `0' failed.
> Actually, opening the file in OpenEV or even running gdalinfo on the 
> file produces the same error, and the program dies.
> Interestingly, I ran gdalinfo.exe from the Windows version of FWTools, 
> and it worked fine, but gave the following warning:
> Warning 1: TIFFFetchNormalTag:ASCII value for tag "Software" does not 
> end in null byte
> ...so I'm guessing this is what's causing the problem under Linux. The 
> files were created by jNexradExplorer, so I'll email the author to see 
> if he can fix it at that end. But is it possible to have the tools warn 
> instead of die on this error? Or, is there something I can do to fix the 
> files as a workaround (a way to strip or rewrite the "Software" tag, 
> perhaps)? This is all part of a scripted batch job, so I'd need to be 
> able to repeat it from a script.


I would be interested in having one of these files to analyse.  FWTools
uses libtiff4 which has a bunch of new assertions that may be overly
sensitive.  Likely it is due to some other specialized tag not meeting
some expectation.

Windows builds apparently don't suffer from this because I happened to
compile the assertions out.

Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | President OSGeo, http://osgeo.org

More information about the FWTools mailing list