[FWTools] openev failure

Yasha Karant ykarant at gmail.com
Mon Oct 5 13:55:35 EST 2009

Your suggestion worked fine.  I just installed the same tar.gz to my 
office workstation (same Centos as my laptop), ran install.sh as root,
issued your command from a terminal application under Xwindows, 
everything worked.  I disposed a copy to my printer, worked fine.
Note that the printer interface is not CUPS, but rather a fork/exec of a 
lpr command -- thus I would manually have to modify the lpr command
in the openev print dialog box to use other than the default printer 
(e.g., a networked color laser printer, my desktop unit being a 
monochrome laser printer).

A question:

the standard eog, etc., linux utilities view/print the major of imaging 
formats, but not yet JPEG2000.  Are there other such formats that 
FWTools handle
that are not handled by the "standard" utilities?


Yasha Karant
ykarant at gmail.com

Frank Warmerdam wrote:
> Yasha Karant wrote:
>> When opening a jpeg2000 (.jp2) file on Centos 5.3 current (RHEL 5.3) 
>> current, IA-32,
>> using openev (that is jp2 compatible)
>> I get the message:
>> /var/local/FWTools-2.0.6/bin/openev: line 25: 14274 Segmentation 
>> fault      ${OPENEV_HOME}/bin/python ${OPENEV_HOME}/pymod/openev.py "$@"
>> I have run install.sh as root and as myself
>> I have done source /var/local/FWTools-2.0.6/fwtools_env.sh from my 
>> shell (bash)
>> /var/local/FWTools-2.0.6 is where I have unpacked the tar.gz 
>> distribution.
> Yasha,
> Could you try adding the -h switch?
>   openev -h your.jp2
> This forces use of local system opengl instead of the distributed 
> software
> opengl and fixes some compatability problems that result in crashes after
> loading the first image.
> Best regards,

More information about the FWTools mailing list