[maplab-users] Error: MapScript Not Found - configuration problem?

Vincent Schut
Wed, 17 Jul 2002 14:59:13 +0200
This is a multi-part message in MIME format...

Content-Type: text/plain;
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

refering my last mail about the mapscript detection being solved... This =
doesn't work anymore in the RC2 version I just installed...=0D
Any clue?=0D
mapscript is loaded in php.ini=0D
the phpinfo.php shows a mapscript section=0D
tht php section in the maplab info.phtml says that mapscript was loaded int=
o =0D
but mapscript is *not* detected in the maplab section...=0D
Cheers Vincent.=0D
On Monday 08 July 2002 13:39, Paul Spencer wrote:=0D
> Vincent, thanks for trying out MapLab.=0D
> Please note that for PHP 4.1.2 there is a bug in the ImageTypes() call=0D
> that causes PHP not to return GIF as a valid image format even if your=0D
> GD library was built with GIF support.  Apparently GIF will work.  This=
> bug is fixed in PHP 4.2.1 along with several others of relevance to the=
> next release of MapLab.  You are encouraged to upgrade to 4.2.1 if=0D
> possible and practical.=0D
> needs to be copied into the PHP extensions directory.=0D
>  You can determine this by typing `php-config --extension-dir` at a=0D
> shell prompt.  One caveat.  This gives you the default path that PHP=0D
> looks for.  This can be changed in your php.ini file (likely in=0D
> /etc/httpd/conf but you can see the php.ini that is being used if you=0D
> load a phpinfo page), so you can also check there to see if you have a=0D
> line similar to `extension_dir =3D /some/path`.  If this line is in your=
> php.ini and not commented out, then you should place mapscript there.=0D
> In your configuration file, you should just put the name=0D
>  No path is required and in fact it won't work if you d=
> For MapServer, you should upgrade to 3.6.2 if possible.  If you are=0D
> using mapserver from cvs, you can get it using cvs update -r=0D
> rel-3-6-0-beta1 (yes, this is the branch name), otherwise you may have=0D
> to wait for a formal release of 3.6.2.  (Version 3.6.1 will work with=0D
> your current version of MapLab, the new version is required for the=0D
> latest MapLab to be released today I hope).=0D
> A simple test for determining if MapScript is set up properly is to=0D
> create a new php page somewhere in your web root:=0D
> <?=0D
> dl("MapScript");=0D
> phpinfo();=0D
> ?>=0D
> When you access this page, you should see no errors at the top and a=0D
> MapScript section about 2/3rds of the way down.=0D
> Please try this and get back to us.=0D
> Cheers,=0D
> Paul Spencer=0D
> Applications and Software Development=0D
> DM Solutions Group=0D
> Vincent Schut wrote:=0D
> >Got things running - a bit. Now I stumbled into the following error: in=
> > the info window, after configuring all things 'properly', in the=0D
> > MapScript Information section, I get the following error: MapScript Not=
> > Found - configuration problem? However, later on it says that the=0D
> > mapscript extension was loaded correctly into php. I tried filling in t=
> > entire path to the extension instead of just in the=0D
> > config field for maplab, without any difference. Should I have (a copy=
> > of) mapscript in a special place to run maplab? Or is something else=0D
> > wrong?=0D
> >All other values are OK (green crosses), except everything in the ms=0D
> >information section. The image types in this section (of course) also sh=
> > a red cross.=0D
> >=0D
> >System is mandrake linux, php 4.1.2 (as cgi), mapserver 3.6.=0D
> >_______________________________________________=0D
> >Maplab-users mailing list=0D
> >
> >

Stichting BOS kleurt de wereld GROEN!=20
Kleur mee op


This archive was generated by Pipermail.