[maplab-users] Problem with libwww

CraSh - Expert Glandeur
Wed, 24 Jul 2002 15:57:36 +0200

After deleting the files which mapserver have installed during make install, I've tried to install the new mapserver 3.6.2 :
./configure --with-proj --with-wmsclient --with-libwww --with-gdal --enable-runpath --with-php=../php-4.2.1 --without-tiff --with-gd --enable-force-freetype1
and after a lot of lines :

gcc -O2  -Wall -DIGNORE_MISSING_DATA  -DUSE_EPPL -DUSE_PROJ -DUSE_PROJ_API_H -DUSE_WMS -DUSE_WMS_LYR   -DUSE_JPEG -DUSE_GD_PNG -DUSE_GD_JPEG -DUSE_GD_WBMP -DUSE_GD_FT    -DUSE_GDAL    -I/usr/include          -I/usr/local/include  -I/usr/local/include -I/usr/local/include/w3c-libwww -DHAVE_CONFIG_H  shp2img.o -Wl,-rpath,/home/ramon/DEGRAEVE/mapserver/mapserver-3.6.2 -L. -lmap -lgd -L/usr/lib -lgd -ljpeg -lttf -lpng -lz  -ljpeg
-lttf -lpng -lz -lproj -ljpeg    -L/usr/local/lib -lgdal.1.1  -L/usr/local/lib -lwwwxml -lxmltok -lxmlparse -lwwwinit -lwwwapp -lwwwhtml -lwwwtelnet -lwwwnews -lwwwhttp -lwwwmime -lwwwgopher -lwwwftp -lwwwfile -lwwwdir -lwwwcache -lwwwstream -lwwwmux -lwwwtrans -lwwwcore -lwwwutils -lmd5 -ldl    -lm   -o shp2img
/usr/local/lib/libwwwcore.a(HTWWWStr.o): In function `HTMessageIdStr':
/home/ramon/DEGRAEVE/mapserver/LIBWWW/Library/src/HTWWWStr.c:360: the use of `tmpnam'
is dangerous, better use `mkstemp'
/usr/local/lib/libwwwcore.a(HTInet.o): In function `HTGetTmpFileName':
/home/ramon/DEGRAEVE/mapserver/LIBWWW/Library/src/HTInet.c:621: the use of `tempnam' is dangerous, better use `mkstemp'
/usr/local/lib/libwwwapp.a(HTInit.o): In function `HTConverterInit':
/home/ramon/DEGRAEVE/mapserver/LIBWWW/Library/src/HTInit.c:87: undefined reference to
/home/ramon/DEGRAEVE/mapserver/LIBWWW/Library/src/HTInit.c:88: undefined reference to

and it stops. I've looked for HTXML_new but i havent found it. and i have installed expat too because it was talking about xml/libwww and it was without effect... if someone has an idea.. =)

Thanks a lot :). 

Frederic Degraeve


"I dont want to crash my program. Sniffff"
>  I've got a problem concerning maplab and mapscript...
> It worked a little but i can't work on.
> Fatal error: Call to undefined function: ms_tokenizemap() in
> /usr/local/httpd/htdocs/maplab/htdocs/mapedit/mapeditapp.php on line 164
> But i have installed successfully the components ans the configuration information url
> says me that it found it well. but i haven't "dl" the component for dbase and i would
> want to know if it is necessary to do it and if it could be my problem.
>  Thanks a lot.
> ------------------------------------------
> Faites un voeu et puis Voila ! 


Faites un voeu et puis Voila ! 

This archive was generated by Pipermail.