[maplab-users] problems with all 4 versions

Nick Feller
Mon, 4 Nov 2002 13:11:55 -0800 (PST)
Hello all,

I have tried to set up all four Maplab versions, and
neither of them work.

Version 3 & dev:
-These kept saying that "my session had expired" (in
mapbrowser, mapedit and gmapfactory.) I removed the
part of the globalprefs.php file that caused the
$gbVoidSession to be set to true (seemed like some
sort of security precaution - wasn't present in rc1 &
2.) I was then able to launch mapbrowser and mapedit.

-The filebrowser always defaults to the /htdocs/common
folder, even though my configuration file was changed
to the root maplab directory. I verified a dozen times
or so that my configuration setting were saved and
correct. (I looked at the xml files themselves too)

Version 1 & 2:
Hooray! The filebrowser worked! No complaints about
sessions being expired! But when I created a .map file
in Mapedit the mapfile would fail to initialize
afterwards, (which I know from reading the logfiles.)
I went to the directory and sure enough the .map file
was created - with just the start and end lines
The only toolbars available in mapedit and mapbrowser
are the open and create map buttons. I would open a
mapfile and the main screens would still display the
initial "no mapfile" display. I can't open the demo
mapfile either - all toolbars stay grey except open
and create!

I am running:

Slackware Linux 8.1

Apache 2.0.43

php 4.2.4(latest) compiled --with-gd --with-dbase
--with-ttf --enable-gd-native-ttf --with-regex=system

MapServer version 3.6.3
from installation info screen in MapLab:

-All of the above work fine together (have run the
GMap demo wothout any problems.)
-I even set the file/ folder permissions to 777 (which
I shouldn't do - but am frustrated, hehe) for the
entire maplab folder & contents.
-The installation information in Maplab has all green
-php.ini has dl enabled &
allow_call_time_pass_reference = on.

Cookies, sessions work in other apps just fine

Can anyone help? This is driving me nuts!
I think I've got the filebrowser issue resolved, but
why won't my maps initialize?

Thanks all!

-Nick Feller
sometimesiam (#at) yahoo (

Do you Yahoo!?
HotJobs - Search new jobs daily now

This archive was generated by Pipermail.