[ms4w-users] cannot start apache services

bill smith paul.smith1st at yahoo.com
Sat Oct 21 03:17:04 EDT 2006

Hi Burt
  I have never installed MS4W before, unless that playing with install/uninstall apache commands may have created unwanted duplication effects. I have seen both “Apache MS4W Web Server” and “apache2” coming along with the first installation attempt. 
  httpd -k -uninstall -n Apache2    (has no effect)
  httpd -k -uninstall -n Apache MS4W Web Server (error message: does not find the specified file)
  httpd -k -install -n Apache MS4W Web Server 
  something wrong with the environmental variables??
  I could not cancel Apache 2 service, I have not control on it at all. It seems that apache services attempt to start and then stop an instant after. I have checked the firewall is off, either Windows and Filseclab.
  Strange fact is that service “Apache MS4W Web Server” only is visible (
yet not possible to be start) by:
  But, why there are two distinct sets of install/uninstall apache commands?
  "Bart van den Eijnden (OSGIS)" <bartvde at osgis.nl> wrote:
  Hi Bill,

what is your second Apache, is it an old MS4W install?

What happens if you deinstall both, and then only install the new one.

httpd -k -uninstall -n Apache2
httpd -k -uninstall -n Apache MS4W Web Server
httpd -k -install -n Apache MS4W Web Server


Best regards,

bill smith schreef:
> Well
> Problem installing MapServer for Windows - MS4W.
> Installation procedure:
> MS4W PHP5 Base Installer v2.2
> Unzip and Installed in C:\ms4w
> RUN C:\ms4w\apache-install.bat
> rebooting PC
> Problem: can’t load page http://localhost/
> When looking in Start > Run 'services.msc',
> two apache services are listed: Apache MS4W Web Server, Apache2.
> Problem: Both services are automatic but appear in stopped status, 
> there’s no way to start them . Tried either double click and command 
> line with
> httpd -k -uninstall -n Apache2
> httpd -k -uninstall -n Apache MS4W Web Server
> httpd -k -install -n Apache2
> httpd -k -install -n Apache MS4W Web Server
> when trying to restart always get the same error logs
> [Fri Oct 20 18:54:15 2006] [notice] Apache/2.2.3 (Win32) configured -- 
> resuming normal operations
> [Fri Oct 20 18:54:15 2006] [notice] Server built: Jul 27 2006 16:49:49
> [Fri Oct 20 18:54:15 2006] [notice] Parent: Created child process 2700
> [Fri Oct 20 18:54:15 2006] [notice] Child 2700: Child process is running
> [Fri Oct 20 18:54:15 2006] [crit] (OS 10022)Invalid argument. : Child 
> 2700: setup_inherited_listeners(), WSASocket failed to open the 
> inherited socket.
> [Fri Oct 20 18:54:16 2006] [crit] Parent: child process exited with 
> status 3 -- Aborting.
> Already verified in service properties the path to the executable is 
> correct.
> In addition could not find the way to uninstall completely the MS4W 
> package, could not uninstall Apache 2 service.
> Welcome any suggestion about how to start Apache services.
> John
> ------------------------------------------------------------------------
> Do you Yahoo!?
> Everyone is raving about the all-new Yahoo! Mail. 
> ------------------------------------------------------------------------
> _______________________________________________
> ms4w-users mailing list
> ms4w-users at lists.maptools.org
> http://lists.maptools.org/mailman/listinfo/ms4w-users

Bart van den Eijnden
OSGIS, Open Source GIS
bartvde at osgis.nl

Do you Yahoo!?
 Get on board. You're invited to try the new Yahoo! Mail.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maptools.org/pipermail/ms4w-users/attachments/20061021/44f0f9cd/attachment-0001.html

More information about the ms4w-users mailing list