[MS4W-Users] Java Mapscript Problem

Neumann, Gabriel | brain-SCC GmbH g.neumann at brain-scc.de
Fri May 21 01:41:59 EST 2010

Hello Tamas!

Thank you for your response. I've tried different things and than I've 
found the solution myself. The problem was the zlib1.dll which was 
loaded from my WLAN driver instead of the version from MS4W. Now I've 
fixed my path order to load the right one. The mentioned errors still 
occurs in the dependency walker but now everything works fine and I 
think I can ignore them.

Beste regards, Gabriel!

Am 20.05.2010 23:20, schrieb Tamas Szekeres:
> 2010/5/20 Neumann, Gabriel | brain-SCC GmbH <g.neumann at brain-scc.de
> <mailto:g.neumann at brain-scc.de>>
>     Hello!
>     I have a problem with the java mapscript under windows xp prof sp3. I've
>     tried different configurations of path/classpath and so on but I got the
>     error "Can't find dependent libraries" every time I load the lib in
>     Java. And I've tested with both versions MS4W 3.0 beta11 and 2.3.1. I
>     have installed the VC8 redistributable too but nothing helps.
>     I have already inspect the mapscript.dll with the dependency walker. So
>     I know that he can't find the missing libraries IESHIMS.DLL and WER.DLL
>     on my computer. Also a fulltext search over all hdd's hasn't found
>     anything. A second error in the dependency walker is with the MPR.DLL ->
>     "unresolved import due to a missing export function in a delay-load
>     dependent module". For my understanding it doesn't matter because they
>     are lazy loaded. But in my Java test application the error occurs
>     pertinaciously.
> Hmmm. I don't see how those dependencies have been introduced in a
> default build. According to the binaries from
> http://vbkto.dyndns.org/sdk/  mapscript.dll seems to depend only on
> libmap.dll, msvcrtxx.dll, kernel32.dll and zlib1.dll.
> Best regards,
> Tamas

More information about the MS4W-Users mailing list