[MS4W-Users] FW: [TinyOWS-users] Problem with installing TinyOWS and MS4W

Rahkonen Jukka Jukka.Rahkonen at mmmtike.fi
Sat Sep 25 01:14:12 EST 2010


Oh, I am so used to test MS4W installation simply by sending http://localhost/cgi-bin/mapserv.exe that I did it automatically also with tinyows.exe. Is there some other way to test that TinyOWS is OK, before going on to configuration?

The problem has definitely something to do with the config.xml. It is not only the PostGIS connection, perhaps wrong schema address is another trouble, but I can't say for sure. I will send you in another mail the edited MS4W config.xml that still gives the same error and another config.xml which I copied from a working Linux installation. If I use that Linux config file instead of MS4W config.xml everything works. I am pretty sure that this will be an easy fix for you. Remember also to correct the cgi-bin directory as well to ms4w\apache\cgi-bin. We MS4W users are not clever with installation problems, all we can do is to unzip and run.


Yewondwossen Assefa wrote:

>  Hi There,

>  Can you try to setup your postgres connection with valid parameters in 
> the config.xml file, making sure that It can connect to a data base? It 
> is currently setup to some values <pg host="" user="postgres" 
> password="postgres" dbname="tinyows_test" port="5432"/>   but should be 
> modified to something valid.
> That might "fix" the error that you are having. If that is the case, I 
> will file a bug for a proper fix and update new binaries.

> regards,

On 21/09/2010 7:10 AM, Yewondwossen Assefa wrote:
>>  Jukka,
>>  Sorry for the delay. I will try to upload/test new binaries this week 
> and send an update.
>> regards,
>> On 21/09/2010 5:14 AM, Rahkonen Jukka wrote:
>>> Hi,
>> While waiting for an answer I started to think that perhaps this is more
>> MS4W problem than TinyOWS problem.
>> -Jukka-
>> <<<<<<<
>> Rahkonen Jukka wrote
>> 15. 9. 2010 13:19
>> Vastaanottaja: TinyOWS users discuss list
>> Aihe: [TinyOWS-users] Problem with installing TinyOWS and MS4W
>>> Hi,
>>> This is what I have done:
>>> Downloaded and unzipped MS4W v. 3.0 beta 11
>> (http://maptools.org/dl/ms4w/ms4w_3.0_beta11.zip)
>> Downloaded and unzipped TinyOWS 0.9.0 for MS4W
>> (http://maptools.org/dl/ms4w/tinyows-0.9.0-ms4w3.0.zip)
>>> * Changed Apache to listen port 8060
>> * Started MS4W and checked that Mapserver answers as usually at
>> http://localhost:8060/cgi-bin/mapserv.exe
>> * Tried to contact tinyows at http://localhost:8060/cgi-bin/tinyows.exe
>> * Noticed that unzipping tinyows zip placed tinyows.exe into directory
>> D:\ms4w\cgi-bin
>> * Thought that the previous is not intentional and moved tinyows.exe
>> into directory D:\ms4w\Apache\cgi-bin
>> * Tried again http://localhost:8060/cgi-bin/tinyows.exe
>>> Now something is happening but unfortunately all I get back is a
>> Windows error report. Headers are like this:
>> AppName: tinyows.exe AppVer: ModName: msvcr90.dll
>> ModVer: 9.0.30729.4148 Offset: 000734d8
>>> Next I tried blindly what happens from command line
>> http://localhost:8060/cgi-bin/tinyows.exe
>>> Result was:
>> Assertion failed: !o->exit, file src\ows\ows_error.c, line 77
>>> This application has requested the Runtime to terminate it in an
>> unusual way.
>> Please contact the application's support team for more information.
>>> My computer is running on Windows XP Pro (SP3).
>>> Have I installed TinyOWS in a wrong way or is it possibly something
>> else that is wrong?
>> -Jukka Rahkonen-
>> _______________________________________________
>> MS4W-Users mailing list
>> MS4W-Users at lists.maptools.org
>> http://lists.maptools.org/mailman/listinfo/ms4w-users

More information about the MS4W-Users mailing list