[MS4W-Users] FW: [TinyOWS-users] Problem with installing TinyOWS and MS4W

Yewondwossen Assefa yassefa at dmsolutions.ca
Mon Sep 27 08:34:35 EST 2010


Getting back to the list to report after working off list with Jukka.

  Few issues in this bug here:

   - error in the ms4w packaging structure: bug has been added into the 
m4w bug list [1]

   - initial error reported on the assert failing in ows.c. This was 
reported and fixed [2]

  -  In Jukka's case,  beside the error reported in [2], there was also  
a problem identifying promptly the problem since the error was not with 
the connection parameters but with the privileges. Here are the 
notes/suggestion sent by Jukka regarding this:

"...TinyOWS users must have proper db rights.

Perhaps we could add to the user documentation something like

You can test the connection setting with ogr2ogr command
C:\ms4w>ogrinfo -ro PG:"dbname=postgis user=www-data password=www-data host=loca
lhost port=5432"

Trying this revealed me what probably was the real problem:

ERROR 1: ERROR:  permission denied for relation geometry_columns

Thus TinyOWS user must have
- read right for the data tables/views (+insert, update, delete for WFS-T)
- select right for geometry_columns

Is this correct or do you know of something more? How about spatial_ref_sys?"

  Hope these notes capture all the issues. Jukka, please update if I am missing something.


[1]: http://bugzilla.maptools.org/show_bug.cgi?id=2265
[2]: http://www.tinyows.org/trac/ticket/58

On 25/09/2010 2:14 AM, Rahkonen Jukka wrote:
>    Hi,
> Oh, I am so used to test MS4W installation simply by sending http://localhost/cgi-bin/mapserv.exe that I did it automatically also with tinyows.exe. Is there some other way to test that TinyOWS is OK, before going on to configuration?
> The problem has definitely something to do with the config.xml. It is not only the PostGIS connection, perhaps wrong schema address is another trouble, but I can't say for sure. I will send you in another mail the edited MS4W config.xml that still gives the same error and another config.xml which I copied from a working Linux installation. If I use that Linux config file instead of MS4W config.xml everything works. I am pretty sure that this will be an easy fix for you. Remember also to correct the cgi-bin directory as well to ms4w\apache\cgi-bin. We MS4W users are not clever with installation problems, all we can do is to unzip and run.
> -Jukka-
> Yewondwossen Assefa wrote:
>>   Hi There,
>>   Can you try to setup your postgres connection with valid parameters in
>> the config.xml file, making sure that It can connect to a data base? It
>> is currently setup to some values<pg host="" user="postgres"
>> password="postgres" dbname="tinyows_test" port="5432"/>    but should be
>> modified to something valid.
>> That might "fix" the error that you are having. If that is the case, I
>> will file a bug for a proper fix and update new binaries.
>> regards,
> On 21/09/2010 7:10 AM, Yewondwossen Assefa wrote:
>>>   Jukka,
>>>   Sorry for the delay. I will try to upload/test new binaries this week
>> and send an update.
>>> regards,
>>> On 21/09/2010 5:14 AM, Rahkonen Jukka wrote:
>>>> Hi,
>>> While waiting for an answer I started to think that perhaps this is more
>>> MS4W problem than TinyOWS problem.
>>> -Jukka-
>>> <<<<<<<
>>> Rahkonen Jukka wrote
>>> 15. 9. 2010 13:19
>>> Vastaanottaja: TinyOWS users discuss list
>>> Aihe: [TinyOWS-users] Problem with installing TinyOWS and MS4W
>>>> Hi,
>>>> This is what I have done:
>>>> Downloaded and unzipped MS4W v. 3.0 beta 11
>>> (http://maptools.org/dl/ms4w/ms4w_3.0_beta11.zip)
>>> Downloaded and unzipped TinyOWS 0.9.0 for MS4W
>>> (http://maptools.org/dl/ms4w/tinyows-0.9.0-ms4w3.0.zip)
>>>> * Changed Apache to listen port 8060
>>> * Started MS4W and checked that Mapserver answers as usually at
>>> http://localhost:8060/cgi-bin/mapserv.exe
>>> * Tried to contact tinyows at http://localhost:8060/cgi-bin/tinyows.exe
>>> * Noticed that unzipping tinyows zip placed tinyows.exe into directory
>>> D:\ms4w\cgi-bin
>>> * Thought that the previous is not intentional and moved tinyows.exe
>>> into directory D:\ms4w\Apache\cgi-bin
>>> * Tried again http://localhost:8060/cgi-bin/tinyows.exe
>>>> Now something is happening but unfortunately all I get back is a
>>> Windows error report. Headers are like this:
>>> AppName: tinyows.exe AppVer: ModName: msvcr90.dll
>>> ModVer: 9.0.30729.4148 Offset: 000734d8
>>>> Next I tried blindly what happens from command line
>>> http://localhost:8060/cgi-bin/tinyows.exe
>>>> Result was:
>>> Assertion failed: !o->exit, file src\ows\ows_error.c, line 77
>>>> This application has requested the Runtime to terminate it in an
>>> unusual way.
>>> Please contact the application's support team for more information.
>>>> My computer is running on Windows XP Pro (SP3).
>>>> Have I installed TinyOWS in a wrong way or is it possibly something
>>> else that is wrong?
>>> -Jukka Rahkonen-
>>> _______________________________________________
>>> MS4W-Users mailing list
>>> MS4W-Users at lists.maptools.org
>>> http://lists.maptools.org/mailman/listinfo/ms4w-users
> _______________________________________________
> MS4W-Users mailing list
> MS4W-Users at lists.maptools.org
> http://lists.maptools.org/mailman/listinfo/ms4w-users

Assefa Yewondwossen
Software Analyst

Email: yassefa at dmsolutions.ca

Phone: (613) 565-5056 (ext 14)
Fax:   (613) 565-0925

More information about the MS4W-Users mailing list