[MS4W-Users] Install on new system issue

Stephen Woodbridge woodbri at swoodbridge.com
Tue Jul 17 13:57:18 EST 2012

Hi Jeff,

I just went thru a first time install on a new system and spend a lot of 
time debugging an simple issue that should probably be noted in the 
install guide.

There is a system prerequiste to have VC++ 200? redistribution libraries 
installed on the system. We used 2008, but I noticed that there are 
2005, 2008, and 2010 redistribution libraries available. I have no idea 
if any or all suffice.

The installed we did was using the ms4w_3.0.4_dev.zip because we needed 
mapcache and these seems to be the only version that has mapcache built 
in it. Maybe the installer already checks for that prereq. We got a very 
cryptic message when we tried to install apache and it took a while and 
some googling to figure out it was missing the redistribution libraries.

Anyway, a note on prereqs would be very helpful in the install document.

I tried to install the same package on my Windows 7 box to see if it 
worked here. And while I didn't get the above issue, I did get this one:

Installing the Apache MS4W Web Server service
The Apache MS4W Web Server service is successfully installed.
Testing httpd.conf....
Errors reported here must be corrected before the service can be started.
(OS 10048)Only one usage of each socket address (protocol/network 
is normally permitted.  : make_sock: could not bind to address
no listening sockets available, shutting down
Unable to open logs
The Apache MS4W Web Server service is starting.
The Apache MS4W Web Server service could not be started.

A service specific error occurred: 1.

More help is available by typing NET HELPMSG 3547.

Which I assume means something like:
a) I already have service grabbing port 80, but I'm not aware of 
anything that should be doing that.
b. Or is is unhappy about being a DHCP host and can't figure out it 

Any thoughts on this one?

I hope this helps someone else.


More information about the MS4W-Users mailing list